kernel: update kernel 4.9 to 4.9.34
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 26 Jun 2017 09:22:11 +0000 (11:22 +0200)
committerStijn Tintel <stijn@linux-ipv6.be>
Tue, 27 Jun 2017 05:21:03 +0000 (07:21 +0200)
- Refreshed all patches
- Adapted 1 (0031-mtd-add-SMEM-parser-for-QCOM-platforms.patch)

Compile tested on: brcm2708, cns3xxx, imx6
Run tested on: brcm2708, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
[Compile and run tested on brcm2708]
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
22 files changed:
include/kernel-version.mk
target/linux/apm821xx/patches-4.9/801-usb-xhci-add-firmware-loader-for-uPD720201-and-uPD72.patch
target/linux/bcm53xx/patches-4.9/700-b53-add-hacky-CPU-port-fixes-for-devices-not-using-p.patch
target/linux/brcm2708/patches-4.9/950-0031-Add-dwc_otg-driver.patch
target/linux/brcm2708/patches-4.9/950-0060-config-Enable-CONFIG_MEMCG-but-leave-it-disabled-due.patch
target/linux/brcm2708/patches-4.9/950-0181-drm-vc4-Fix-OOPSes-from-trying-to-cache-a-partially-.patch
target/linux/cns3xxx/patches-4.9/130-Extend-PCIE_BUS_PEER2PEER-to-set-MRSS-128-to-fix-CNS3xxx-BM-DMA..patch
target/linux/generic/patches-4.9/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
target/linux/generic/patches-4.9/702-phy_add_aneg_done_function.patch
target/linux/generic/patches-4.9/703-phy-add-detach-callback-to-struct-phy_driver.patch
target/linux/generic/patches-4.9/704-phy-no-genphy-soft-reset.patch
target/linux/generic/patches-4.9/721-phy_packets.patch
target/linux/generic/patches-4.9/930-crashlog.patch
target/linux/ipq806x/patches-4.9/0031-mtd-add-SMEM-parser-for-QCOM-platforms.patch
target/linux/ipq806x/patches-4.9/605-net-IPQ4019-needs-rfs-vlan_tag-callbacks-in.patch
target/linux/lantiq/patches-4.9/0001-MIPS-lantiq-add-pcie-driver.patch
target/linux/lantiq/patches-4.9/0101-find_active_root.patch
target/linux/mvebu/patches-4.9/100-find_active_root.patch
target/linux/mvebu/patches-4.9/400-phy-provide-a-hook-for-link-up-link-down-events.patch
target/linux/mvebu/patches-4.9/407-net-phy-add-802.3-clause-45-support-to-phylib.patch
target/linux/mvebu/patches-4.9/415-phylink-add-phylink-infrastructure.patch
target/linux/pistachio/patches-4.9/413-mtd-Introduce-SPI-NAND-framework.patch

index bbb2b1e47b37cb628e270c5d9be697bc12479ed4..fd6b5280ab3b97d97716ec011f6c491b8fc0aed4 100644 (file)
@@ -4,11 +4,11 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .43
 LINUX_VERSION-4.4 = .71
-LINUX_VERSION-4.9 = .31
+LINUX_VERSION-4.9 = .34
 
 LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
 LINUX_KERNEL_HASH-4.4.71 = 44cd5532d6df32197fd0f89e6f8c542fcfb76b52155a4d3a609ef4898522e6ab
-LINUX_KERNEL_HASH-4.9.31 = 28cad8b66216da2550155b7a77f37041bde40b821567d1b288e5e9fb6cca9856
+LINUX_KERNEL_HASH-4.9.34 = 13d159d1b1fa41ea19fcc2defe09d7532f312ee0b8279b8e12c961d8b02a4546
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index 91c5c1ff102324dae48013ad8c8c036236c44b7b..39c0db3b73e4d6afe66c4946f2eb7dd0cb2fcc8e 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
  
  #include "xhci.h"
  #include "xhci-trace.h"
-@@ -227,6 +229,458 @@ static void xhci_pme_acpi_rtd3_enable(st
+@@ -230,6 +232,458 @@ static void xhci_pme_acpi_rtd3_enable(st
  static void xhci_pme_acpi_rtd3_enable(struct pci_dev *dev) { }
  #endif /* CONFIG_ACPI */
  
@@ -503,7 +503,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
  /* called during probe() after chip reset completes */
  static int xhci_pci_setup(struct usb_hcd *hcd)
  {
-@@ -266,6 +720,22 @@ static int xhci_pci_probe(struct pci_dev
+@@ -269,6 +723,22 @@ static int xhci_pci_probe(struct pci_dev
        struct hc_driver *driver;
        struct usb_hcd *hcd;
  
@@ -526,7 +526,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
        driver = (struct hc_driver *)id->driver_data;
  
        /* Prevent runtime suspending between USB-2 and USB-3 initialization */
-@@ -323,6 +793,16 @@ static void xhci_pci_remove(struct pci_d
+@@ -326,6 +796,16 @@ static void xhci_pci_remove(struct pci_d
  {
        struct xhci_hcd *xhci;
  
index 2ee9cd48765539a9fbd5d09b51f1cd6558ab48ee..bafa4e4b1d680663de930245fec958c1b488ae38 100644 (file)
@@ -13,16 +13,16 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
 
 --- a/drivers/net/phy/b53/b53_common.c
 +++ b/drivers/net/phy/b53/b53_common.c
-@@ -25,6 +25,7 @@
- #include <linux/module.h>
- #include <linux/switch.h>
+@@ -27,6 +27,7 @@
+ #include <linux/of.h>
+ #include <linux/of_net.h>
  #include <linux/platform_data/b53.h>
 +#include <linux/of.h>
  
  #include "b53_regs.h"
  #include "b53_priv.h"
-@@ -1383,6 +1384,28 @@ static int b53_switch_init(struct b53_de
-                       sw_dev->cpu_port = 5;
+@@ -1522,6 +1523,28 @@ static int b53_switch_init(struct b53_de
+                       return ret;
        }
  
 +      /* Set correct CPU port */
index 3b17e9711d7e3283fa5a02cf35f678c6429956b0..6f7af04343d5042b03a81f3318d5a4492e847dcf 100644 (file)
@@ -696,7 +696,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
  }
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -5034,7 +5034,7 @@ static void port_event(struct usb_hub *h
+@@ -5040,7 +5040,7 @@ static void port_event(struct usb_hub *h
        if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
                u16 status = 0, unused;
  
index e17a84d4f0de9db4c679decfa617f64a1d3d5db6..48c9b7b590a1908cd634631ac364469a99b7f95b 100644 (file)
@@ -10,7 +10,7 @@ Subject: [PATCH] config: Enable CONFIG_MEMCG, but leave it disabled (due to
 
 --- a/kernel/cgroup.c
 +++ b/kernel/cgroup.c
-@@ -5627,7 +5627,7 @@ int __init cgroup_init_early(void)
+@@ -5632,7 +5632,7 @@ int __init cgroup_init_early(void)
        return 0;
  }
  
@@ -19,7 +19,7 @@ Subject: [PATCH] config: Enable CONFIG_MEMCG, but leave it disabled (due to
  
  /**
   * cgroup_init - cgroup initialization
-@@ -6164,6 +6164,28 @@ static int __init cgroup_no_v1(char *str
+@@ -6169,6 +6169,28 @@ static int __init cgroup_no_v1(char *str
  }
  __setup("cgroup_no_v1=", cgroup_no_v1);
  
index 000f3a8df374156c81f323e606923b92cb729b56..3fed370bee5ccedb42b1fe3141ab0a4d7c469254 100644 (file)
@@ -17,7 +17,7 @@ Fixes: c826a6e10644 ("drm/vc4: Add a BO cache.")
 
 --- a/drivers/gpu/drm/vc4/vc4_bo.c
 +++ b/drivers/gpu/drm/vc4/vc4_bo.c
-@@ -314,6 +314,14 @@ void vc4_free_object(struct drm_gem_obje
+@@ -322,6 +322,14 @@ void vc4_free_object(struct drm_gem_obje
                goto out;
        }
  
index aae4488f6e839d55ad17978d0ded84d1c36dfe60..3e28b7e3cd043763d66ecf33487d7e2a2064c1de 100644 (file)
@@ -12,7 +12,7 @@
        /* For Max performance, the MRRS must be set to the largest supported
 --- a/include/linux/pci.h
 +++ b/include/linux/pci.h
-@@ -778,7 +778,7 @@ enum pcie_bus_config_types {
+@@ -783,7 +783,7 @@ enum pcie_bus_config_types {
        PCIE_BUS_DEFAULT,       /* ensure MPS matches upstream bridge */
        PCIE_BUS_SAFE,          /* use largest MPS boot-time devices support */
        PCIE_BUS_PERFORMANCE,   /* use MPS and MRRS for best performance */
index 99d029ce688aa10e60b69f97ad7df8eb4e7c7693..4a81e751ddde3ac85241a57b6eb9596010e3478c 100644 (file)
@@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        return 0;
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -1748,6 +1748,8 @@ struct net_device {
+@@ -1749,6 +1749,8 @@ struct net_device {
        struct netdev_hw_addr_list      mc;
        struct netdev_hw_addr_list      dev_addrs;
  
index d38212da7b385231fbc9a335a7ba054916efaab7..5f71be60b8b6d7ac4ce826d04ab6e483273366a7 100644 (file)
@@ -15,7 +15,7 @@
  
 --- a/drivers/net/phy/phy_device.c
 +++ b/drivers/net/phy/phy_device.c
-@@ -1247,6 +1247,9 @@ int genphy_update_link(struct phy_device
+@@ -1267,6 +1267,9 @@ int genphy_update_link(struct phy_device
  {
        int status;
  
index c9e9b695ea3c0fda64c1e467aab6d74e9e918b26..68b60ac4a85541145b65f943c7a9d58ddbf2ddff 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/phy_device.c
 +++ b/drivers/net/phy/phy_device.c
-@@ -983,6 +983,9 @@ void phy_detach(struct phy_device *phyde
+@@ -1001,6 +1001,9 @@ void phy_detach(struct phy_device *phyde
        struct mii_bus *bus;
        int i;
  
index 8ea34e28e384e8738e07ad3fe565c468c8906803..6672bbe8a26c834343ac4a5ccdcbf026c985edf5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/phy_device.c
 +++ b/drivers/net/phy/phy_device.c
-@@ -1465,7 +1465,7 @@ int genphy_config_init(struct phy_device
+@@ -1485,7 +1485,7 @@ int genphy_config_init(struct phy_device
        return 0;
  }
  
@@ -9,7 +9,7 @@
  {
        /* Do nothing for now */
        return 0;
-@@ -1704,7 +1704,7 @@ static struct phy_driver genphy_driver[]
+@@ -1724,7 +1724,7 @@ static struct phy_driver genphy_driver[]
        .phy_id         = 0xffffffff,
        .phy_id_mask    = 0xffffffff,
        .name           = "Generic PHY",
@@ -18,7 +18,7 @@
        .config_init    = genphy_config_init,
        .features       = PHY_GBIT_FEATURES | SUPPORTED_MII |
                          SUPPORTED_AUI | SUPPORTED_FIBRE |
-@@ -1718,7 +1718,7 @@ static struct phy_driver genphy_driver[]
+@@ -1738,7 +1738,7 @@ static struct phy_driver genphy_driver[]
        .phy_id         = 0xffffffff,
        .phy_id_mask    = 0xffffffff,
        .name           = "Generic 10G PHY",
index 5b4ff07d992d081b650f9af47df238370ff26540..717aba8ffbc26891923bc5c8210eb28125fc1457 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -1397,6 +1397,7 @@ enum netdev_priv_flags {
+@@ -1398,6 +1398,7 @@ enum netdev_priv_flags {
        IFF_RXFH_CONFIGURED             = 1<<25,
        IFF_PHONY_HEADROOM              = 1<<26,
        IFF_MACSEC                      = 1<<27,
@@ -8,7 +8,7 @@
  };
  
  #define IFF_802_1Q_VLAN                       IFF_802_1Q_VLAN
-@@ -1426,6 +1427,7 @@ enum netdev_priv_flags {
+@@ -1427,6 +1428,7 @@ enum netdev_priv_flags {
  #define IFF_TEAM                      IFF_TEAM
  #define IFF_RXFH_CONFIGURED           IFF_RXFH_CONFIGURED
  #define IFF_MACSEC                    IFF_MACSEC
@@ -16,7 +16,7 @@
  
  /**
   *    struct net_device - The DEVICE structure.
-@@ -1712,6 +1714,11 @@ struct net_device {
+@@ -1713,6 +1715,11 @@ struct net_device {
        const struct ndisc_ops *ndisc_ops;
  #endif
  
@@ -28,7 +28,7 @@
        const struct header_ops *header_ops;
  
        unsigned int            flags;
-@@ -1779,6 +1786,10 @@ struct net_device {
+@@ -1780,6 +1787,10 @@ struct net_device {
        struct mpls_dev __rcu   *mpls_ptr;
  #endif
  
index a2e2180706df20672bb86c02c13c11b464ec8d8c..e9041384355d7cf2739338f27e8c717a532b3717 100644 (file)
@@ -33,7 +33,7 @@
        depends on BROKEN || !FRV
 --- a/kernel/Makefile
 +++ b/kernel/Makefile
-@@ -112,6 +112,7 @@ obj-$(CONFIG_TORTURE_TEST) += torture.o
+@@ -113,6 +113,7 @@ obj-$(CONFIG_TORTURE_TEST) += torture.o
  obj-$(CONFIG_MEMBARRIER) += membarrier.o
  
  obj-$(CONFIG_HAS_IOMEM) += memremap.o
index d956a3b0698f9e9ce37b601a97ca93b5a7b7b4f1..ad0b09b115c7ad548915fab9c3c95c4943ba0ba0 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: Ram Chandra Jangir <rjangi@codeaurora.org>
 
 --- a/drivers/mtd/Kconfig
 +++ b/drivers/mtd/Kconfig
-@@ -190,6 +190,13 @@ config MTD_MYLOADER_PARTS
+@@ -194,6 +194,13 @@ config MTD_MYLOADER_PARTS
          You will still need the parsing functions to be called by the driver
          for your particular device. It won't happen automatically.
  
@@ -270,6 +270,6 @@ Signed-off-by: Ram Chandra Jangir <rjangi@codeaurora.org>
  obj-$(CONFIG_MTD_BCM47XX_PARTS)       += bcm47xxpart.o
  obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
 +obj-$(CONFIG_MTD_QCOM_SMEM_PARTS) += qcom_smem_part.o
+ obj-y                         += parsers/
  
  # 'Users' - code which presents functionality to userspace.
- obj-$(CONFIG_MTD_BLKDEVS)     += mtd_blkdevs.o
index e7ff12142acb20e312ca5dde82e8486d739be3f9..d2721875a2255875a636498f3701b75bb85f6cf6 100644 (file)
@@ -41,7 +41,7 @@ Reviewed-by: Grant Grundler <grundler@chromium.org>
  /*
   * This structure holds all XPS maps for device.  Maps are indexed by CPU.
   */
-@@ -1250,6 +1260,9 @@ struct net_device_ops {
+@@ -1251,6 +1261,9 @@ struct net_device_ops {
                                                     const struct sk_buff *skb,
                                                     u16 rxq_index,
                                                     u32 flow_id);
index 59d29d838be18db8692910e48fd8e7c1f9f2ae3b..59f3b1ae9f77ae5981d0e6e93b23643769e3fdc6 100644 (file)
@@ -5494,7 +5494,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
          (transaction layer end-to-end CRC checking).
 --- a/include/linux/pci.h
 +++ b/include/linux/pci.h
-@@ -1245,6 +1245,8 @@ void pci_walk_bus(struct pci_bus *top, i
+@@ -1250,6 +1250,8 @@ void pci_walk_bus(struct pci_bus *top, i
                  void *userdata);
  int pci_cfg_space_size(struct pci_dev *dev);
  unsigned char pci_bus_max_busnr(struct pci_bus *bus);
index 2faec3478b8a1175a78a21b4098562ebc3b82cdd..7232ffa416963a5147792090c8323df59ac658ac 100644 (file)
@@ -60,7 +60,7 @@
                return -ENOMEM;
  
        i = 0;
-@@ -120,12 +155,22 @@ static int parse_ofpart_partitions(struc
+@@ -121,12 +156,22 @@ static int parse_ofpart_partitions(struc
                if (of_get_property(pp, "lock", &len))
                        parts[i].mask_flags |= MTD_POWERUP_LOCK;
  
@@ -83,7 +83,7 @@
        *pparts = parts;
        return nr_parts;
  
-@@ -136,6 +181,7 @@ ofpart_fail:
+@@ -137,6 +182,7 @@ ofpart_fail:
  ofpart_none:
        of_node_put(pp);
        kfree(parts);
index b8e8c92aababeffcb5e427e231b3c7291e1eeafe..d6006b74448c2ef91b39b08facb0994bb93bb223 100644 (file)
@@ -22,9 +22,9 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
        struct device_node *pp;
        int nr_parts, i, ret = 0;
        bool dedicated = true;
-@@ -109,9 +112,13 @@ static int parse_ofpart_partitions(struc
-               parts[i].offset = of_read_number(reg, a_cells);
+@@ -110,9 +113,13 @@ static int parse_ofpart_partitions(struc
                parts[i].size = of_read_number(reg + a_cells, s_cells);
+               parts[i].of_node = pp;
  
 -              partname = of_get_property(pp, "label", &len);
 -              if (!partname)
@@ -39,7 +39,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
                parts[i].name = partname;
  
                if (of_get_property(pp, "read-only", &len))
-@@ -212,6 +219,18 @@ static int __init ofpart_parser_init(voi
+@@ -213,6 +220,18 @@ static int __init ofpart_parser_init(voi
        return 0;
  }
  
index 268243c0fb2537376eed9114f1f1197a895bea13..c5bb0c02f24e67fb8c02b01a509dbb95bd4c1890 100644 (file)
@@ -157,7 +157,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
  /**
   * phy_prepare_link - prepares the PHY layer to monitor link status
   * @phydev: target phy_device struct
-@@ -899,6 +912,7 @@ int phy_attach_direct(struct net_device
+@@ -910,6 +923,7 @@ int phy_attach_direct(struct net_device
                goto error;
        }
  
index 8e983cc7ffdee06b3a83612a7d8cdca66faae99b..352d6783284849841fa1aadc5cac8b8056dadd19 100644 (file)
@@ -258,7 +258,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
 +EXPORT_SYMBOL_GPL(genphy_c45_read_pma);
 --- a/drivers/net/phy/phy_device.c
 +++ b/drivers/net/phy/phy_device.c
-@@ -1390,27 +1390,19 @@ EXPORT_SYMBOL(genphy_read_status);
+@@ -1410,27 +1410,19 @@ EXPORT_SYMBOL(genphy_read_status);
  
  static int gen10g_read_status(struct phy_device *phydev)
  {
index 87c0daf1787cceb808d0f04bb6e3426323c0e618..fe3f7c2972c479179d81a49940d850d8b3954842 100644 (file)
@@ -83,14 +83,14 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
  obj-$(CONFIG_SWCONFIG)                += swconfig.o
 --- a/drivers/net/phy/phy_device.c
 +++ b/drivers/net/phy/phy_device.c
-@@ -1003,6 +1003,7 @@ void phy_detach(struct phy_device *phyde
+@@ -1021,6 +1021,7 @@ void phy_detach(struct phy_device *phyde
        phydev->attached_dev->phydev = NULL;
        phydev->attached_dev = NULL;
        phy_suspend(phydev);
 +      phydev->phylink = NULL;
  
-       /* If the device had no specific driver before (i.e. - it
-        * was using the generic driver), we unbind the device
+       module_put(phydev->mdio.dev.driver->owner);
 --- /dev/null
 +++ b/drivers/net/phy/phylink.c
 @@ -0,0 +1,903 @@
index ab5d74ad7293a3554164c71e93c3b866633f5ecb..b13dde711570892724ee9dce9252954292a32831 100644 (file)
@@ -46,7 +46,7 @@ Signed-off-by: Ian Pozella <Ian.Pozella@imgtec.com>
 
 --- a/drivers/mtd/Kconfig
 +++ b/drivers/mtd/Kconfig
-@@ -369,6 +369,8 @@ source "drivers/mtd/onenand/Kconfig"
+@@ -373,6 +373,8 @@ source "drivers/mtd/onenand/Kconfig"
  
  source "drivers/mtd/lpddr/Kconfig"
  
@@ -57,7 +57,7 @@ Signed-off-by: Ian Pozella <Ian.Pozella@imgtec.com>
  source "drivers/mtd/ubi/Kconfig"
 --- a/drivers/mtd/Makefile
 +++ b/drivers/mtd/Makefile
-@@ -35,5 +35,6 @@ inftl-objs           := inftlcore.o inftlmount.o
+@@ -36,5 +36,6 @@ inftl-objs           := inftlcore.o inftlmount.o
  
  obj-y         += chips/ lpddr/ maps/ devices/ nand/ onenand/ tests/