sunxi: Added profile for HAOYU Electronics Marsboard A10
authorKayo Phoenix <kayo@illumium.org>
Sun, 22 Oct 2017 20:21:25 +0000 (22:21 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 6 Nov 2017 15:39:41 +0000 (16:39 +0100)
The MarsBoard was a short-lived credit-card sized, extendable board with an Allwinner A10 SoC.
http://linux-sunxi.org/MarsBoard_A10

Signed-off-by: Kayo Phoenix <kayo@illumium.org>
[Forward-ported to new target layout:]
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/boot/uboot-sunxi/Makefile
target/linux/sunxi/image/cortex-a8.mk

index 50c6b06a71370f225ddd678a98dc34d8ac49de2b..d986f6259c745edd2b0a0f715189ff1601617bae 100644 (file)
@@ -96,6 +96,12 @@ define U-Boot/Hummingbird_A31
   NAME:=Hummingbird A31 board
 endef
 
+define U-Boot/Marsboard
+  BUILD_SUBTARGET:=cortexa8
+  NAME:=Marsboard
+  BUILD_DEVICES:=sun4i-a10-marsboard
+endef
+
 define U-Boot/Mele_M9
   BUILD_SUBTARGET:=cortexa7
   NAME:=Mele M9 (A31)
index 97e033dbb3c45137be91f8da444ef548031cce93..564a66f93861f733079fa9343467fb208cd1cef9 100644 (file)
@@ -56,4 +56,14 @@ endef
 
 TARGET_DEVICES += sun4i-a10-pcduino
 
+
+define Device/sun4i-a10-marsboard
+  DEVICE_TITLE:=HAOYU Electronics Marsboard A10
+  DEVICE_PACKAGES:=mod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi sound-soc-sunxi
+  SUPPORTED_DEVICES:=marsboard,a10-marsboard
+  SUNXI_DTS:=sun4i-a10-marsboard
+endef
+
+TARGET_DEVICES += sun4i-a10-marsboard
+
 endif