ath79: add support of D-Link DIR-825 B1
authorDmitry Tunin <hanipouspilot@gmail.com>
Thu, 9 Aug 2018 17:49:29 +0000 (20:49 +0300)
committerMathias Kresin <dev@kresin.me>
Sat, 11 Aug 2018 19:45:04 +0000 (21:45 +0200)
Add support for the ar71xx supported D-Link DIR-825 B1 to ath79.

Signed-off-by: Dmitry Tunin <hanipouspilot@gmail.com>
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
target/linux/ath79/dts/ar7161_dlink_dir-825-b1.dts [new file with mode: 0644]
target/linux/ath79/image/generic.mk

index 79b39b22f4a44abcf47a256ea298d7bc8496d6a1..5edfd9e2ceca03a3c3ea5d880dbf794518897dc8 100755 (executable)
@@ -30,6 +30,11 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth1" "1:lan" "2:lan" "3:lan" "4:lan" "5:wan" "6@eth0"
                ;;
+       dlink,dir-825-b1)
+               ucidef_set_interface_wan "eth1"
+               ucidef_add_switch "switch0" \
+                       "0:lan" "1:lan" "2:lan" "3:lan" "5@eth0"
+               ;;
        embeddedwireless,dorin)
                ucidef_add_switch "switch0" \
                        "0@eth0" "1:wan" "2:lan:3" "3:lan:2"
@@ -143,6 +148,10 @@ ath79_setup_macs()
        avm,fritz300e)
                lan_mac=$(fritz_tffs -n maca -i $(find_mtd_part "tffs (1)"))
                ;;
+       dlink,dir-825-b1)
+               lan_mac=$(mtd_get_mac_text "caldata" 65440)
+               wan_mac=$(mtd_get_mac_text "caldata" 65460)
+               ;;
        phicomm,k2t)
                lan_mac=$(k2t_get_mac "lan_mac")
                wan_mac=$(k2t_get_mac "wan_mac")
index cd8f19be39253c1a968fb6cf2b22a943afacaa7e..95778595480f3de0bddd459ad1584a58f70e5f04 100644 (file)
@@ -129,4 +129,26 @@ case "$FIRMWARE" in
                ;;
        esac
        ;;
+"ath9k-eeprom-pci-0000:00:11.0.bin")
+       case $board in
+       dlink,dir-825-b1)
+               ath9k_eeprom_extract "caldata" 4096 3768
+               ath9k_patch_fw_mac_crc $(mtd_get_mac_text "caldata" 65440) 524
+               ;;
+       *)
+               ath9k_eeprom_die "board $board is not supported yet"
+               ;;
+       esac
+       ;;
+"ath9k-eeprom-pci-0000:00:12.0.bin")
+       case $board in
+       dlink,dir-825-b1)
+               ath9k_eeprom_extract "caldata" 20480 3768
+               ath9k_patch_fw_mac_crc $(macaddr_add $(mtd_get_mac_text "caldata" 65460) 1) 524
+               ;;
+       *)
+               ath9k_eeprom_die "board $board is not supported yet"
+               ;;
+       esac
+       ;;
 esac
diff --git a/target/linux/ath79/dts/ar7161_dlink_dir-825-b1.dts b/target/linux/ath79/dts/ar7161_dlink_dir-825-b1.dts
new file mode 100644 (file)
index 0000000..489f4a4
--- /dev/null
@@ -0,0 +1,247 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar7100.dtsi"
+
+/ {
+       compatible = "dlink,dir-825-b1", "qca,ar7161";
+       model = "D-Link DIR825B1";
+
+       aliases {
+               led-status = &orange_power;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       extosc: ref {
+               compatible = "fixed-clock";
+               #clock-cells = <0>;
+               clock-output-names = "ref";
+               clock-frequency = <40000000>;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+               blue_usb {
+                       label = "d-link:blue:usb";
+                       gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+                       trigger-sources = <&usb_ochi_port>, <&usb_echi_port>;
+                       linux,default-trigger = "usbport";
+               };
+
+               orange_power: orange_power {
+                       label = "d-link:orange:power";
+                       gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+               };
+
+               blue_power {
+                       label = "d-link:blue:power";
+                       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+
+               blue_wps {
+                       label = "d-link:blue:wps";
+                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+
+               orange_planet {
+                       label = "d-link:orange:planet";
+                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+
+               blue_planet {
+                       label = "d-link:blue:planet";
+                       gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+       };
+
+       ath9k-leds {
+               compatible = "gpio-leds";
+
+               wlan2g {
+                       label = "d-link:blue:wlan2g";
+                       gpios = <&ath9k0 5 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               wlan5g {
+                       label = "d-link:blue:wlan5g";
+                       gpios = <&ath9k1 5 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+                       linux,default-trigger = "phy1tpt";
+               };
+
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+
+               wps {
+                       label = "wps";
+                       linux,code = <KEY_WPS_BUTTON>;
+                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       rtl8366s {
+               compatible = "realtek,rtl8366s";
+               gpio-sda = <&gpio 5 GPIO_ACTIVE_HIGH>;
+               gpio-sck = <&gpio 7 GPIO_ACTIVE_HIGH>;
+               realtek,initvals = <0x06 0x0108>;
+
+               mdio-bus {
+                       #address-cells = <1>;
+                       #size-cells = <0>;
+                       status = "okay";
+
+                       phy-mask = <0x10>;
+
+                       phy4: ethernet-phy@4 {
+                               reg = <4>;
+                               phy-mode = "rgmii";
+                       };
+               };
+       
+       };
+};
+
+
+&usb1 {
+       #address-cells = <1>;
+       #size-cells = <0>;
+       status = "okay";
+
+       usb_ochi_port: port@1 {
+               reg = <1>;
+               #trigger-source-cells = <0>;
+       };
+};
+
+&usb2 {
+       #address-cells = <1>;
+       #size-cells = <0>;
+       status = "okay";
+
+       usb_echi_port: port@1 {
+               reg = <1>;
+               #trigger-source-cells = <0>;
+       };
+};
+
+&usb_phy {
+       status = "okay";
+};
+
+&pcie0 {
+       status = "okay";
+
+       ath9k0: wifi@0,11 {
+               compatible = "pci168c,0029";
+               reg = <0x8800 0 0 0 0>;
+               qca,no-eeprom;
+               #gpio-cells = <2>;
+               gpio-controller;
+       };
+
+       ath9k1: wifi@0,12 {
+               compatible = "pci168c,0029";
+               reg = <0x9000 0 0 0 0>;
+               qca,no-eeprom;
+               #gpio-cells = <2>;
+               gpio-controller;
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&pll {
+    clocks = <&extosc>;
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "config";
+                               reg = <0x040000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@50000 {
+                               label = "firmware";
+                               reg = <0x050000 0x610000>;
+                       };
+
+                       caldata: partition@60000 {
+                               label = "caldata";
+                               reg = <0x660000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@670000 {
+                               label = "unknown";
+                               reg = <0x670000 0x190000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+
+&eth0 {
+       status = "okay";
+       pll-data = <0x11110000 0x00001099 0x00991099>;
+
+       fixed-link {
+               speed = <1000>;
+               full-duplex;
+       };
+
+};
+
+&eth1 {
+       status = "okay";
+       pll-data = <0x11110000 0x00001099 0x00991099>;
+
+       phy-handle = <&phy4>;
+
+};
index 614b3371f32e2ecfa1a7fcefff26bc45934b5fb6..767d635cfbf320bcbbd62f493b3ef6889d8107ff 100644 (file)
@@ -22,6 +22,16 @@ define Device/buffalo_wzr-hp-g450h
 endef
 TARGET_DEVICES += buffalo_wzr-hp-g450h
 
+define Device/dlink_dir-825-b1
+  ATH_SOC := ar7161
+  DEVICE_TITLE := D-LINK DIR-825 B1
+  IMAGE_SIZE := 6208k
+  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport kmod-leds-reset kmod-owl-loader
+  SUPPORTED_DEVICES += dir-825-b1
+endef
+TARGET_DEVICES += dlink_dir-825-b1
+
 define Device/embeddedwireless_dorin
   ATH_SOC := ar9331
   DEVICE_TITLE := Embedded Wireless Dorin