lantiq: remove gr7000 support
authorJohn Crispin <john@phrozen.org>
Tue, 21 Jun 2016 09:57:24 +0000 (11:57 +0200)
committerJohn Crispin <john@phrozen.org>
Wed, 22 Jun 2016 17:32:06 +0000 (19:32 +0200)
this seems to have never worked as the wrong SoC is selected

Signed-off-by: John Crispin <john@phrozen.org>
target/linux/lantiq/base-files/etc/board.d/02_network
target/linux/lantiq/dts/GR7000.dts [deleted file]
target/linux/lantiq/image/Makefile

index cafcb0e00972829329e52d75fb86bb48df071dd9..6d9f8fdeee1b39dacadb334971001cb0857f012e 100755 (executable)
@@ -76,10 +76,6 @@ FRITZ7360SL)
                "4:lan:1" "2:lan:2" "0:lan:3" "1:lan:4" "6t@eth0"
        ;;
 
-GR7000)
-       ucidef_set_interface_wan "eth0"
-       ;;
-
 H201L)
        ucidef_add_switch "switch0" \
                "0:lan:1" "1:lan:2" "2:lan:3" "3:lan:4" "4t@eth0"
diff --git a/target/linux/lantiq/dts/GR7000.dts b/target/linux/lantiq/dts/GR7000.dts
deleted file mode 100644 (file)
index 220eb47..0000000
+++ /dev/null
@@ -1,149 +0,0 @@
-/dts-v1/;
-
-/include/ "ar9.dtsi"
-
-/ {
-       model = "GR7000 - Aztech GR7000";
-
-       chosen {
-               bootargs = "console=ttyLTQ0,115200 init=/etc/preinit";
-
-               leds {
-                       boot = &power_red;
-                       failsafe = &power_red;
-
-                       internet = &internet_green;
-                       usb = &usb;
-                       wifi = &wifi;
-               };
-       };
-
-       memory@0 {
-               reg = <0x0 0x2000000>;
-       };
-
-       fpi@10000000 {
-               localbus@0 {
-                       nor-boot@0 {
-                               compatible = "lantiq,nor";
-                               bank-width = <2>;
-                               reg = <0 0x0 0x2000000>;
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-
-                               partitions {
-                                       compatible = "fixed-partitions";
-                                       #address-cells = <1>;
-                                       #size-cells = <1>;
-
-                                       partition@0 {
-                                               label = "uboot";
-                                               reg = <0x0 0x20000>;
-                                               read-only;
-                                       };
-
-                                       partition@20000 {
-                                               label = "uboot_env";
-                                               reg = <0x20000 0x10000>;
-                                               read-only;
-                                       };
-
-                                       partition@30000 {
-                                               label = "firmware";
-                                               reg = <0x30000 0x7d0000>;
-                                       };
-                               };
-                       };
-               };
-
-               gpio: pinmux@E100B10 {
-                       compatible = "lantiq,pinctrl-xr9";
-                       pinctrl-names = "default";
-                       pinctrl-0 = <&state_default>;
-
-                       state_default: pinmux {
-                               stp {
-                                       lantiq,groups = "stp";
-                                       lantiq,function = "stp";
-                               };
-                               pci-in {
-                                       lantiq,groups = "req1";
-                                       lantiq,output = <0>;
-                                       lantiq,open-drain = <1>;
-                                       lantiq,pull = <2>;
-                               };
-                               pci-out {
-                                       lantiq,groups = "gnt1";
-                                       lantiq,output = <1>;
-                                       lantiq,pull = <0>;
-                               };
-                               pci_rst {
-                                       lantiq,pins = "io21";
-                                       lantiq,pull = <0>;
-                                       lantiq,output = <1>;
-                               };
-                       };
-               };
-
-               ifxhcd@E101000 {
-                       status = "okay";
-               };
-
-               pci@E105400 {
-                       status = "okay";
-               };
-
-               stp: stp@E100BB0 {
-                       compatible = "lantiq,gpio-stp-xway";
-                       #gpio-cells = <2>;
-                       gpio-controller;
-                       reg = <0xE100BB0 0x40>;
-
-                       lantiq,shadow = <0xfff>;
-                       lantiq,groups = <0x3>;
-               };
-       };
-
-       gpio-keys-polled {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <100>;
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio 53 1>;
-                       linux,code = <0x198>;
-               };
-               wps {
-                       label = "wps";
-                       gpios = <&gpio 54 1>;
-                       linux,code = <0x211>;
-               };
-       };
-
-       gpio-leds {
-               compatible = "gpio-leds";
-
-               power_red: power2 {
-                       label = "gr7000:red:power";
-                       gpios = <&stp 4 0>;
-               };
-               internet_green: internet {
-                       label = "gr7000:green:internet";
-                       gpios = <&stp 2 1>;
-               };
-               internet2 {
-                       label = "gr7000:red:internet";
-                       gpios = <&stp 3 1>;
-               };
-               usb: usb {
-                       label = "gr7000:green:usb";
-                       gpios = <&stp 10 1>;
-               };
-               wifi: wifi {
-                       label = "gr7000:green:wireless";
-                       gpios = <&stp 15 1>;
-               };
-       };
-};
index e0a28c227f29dc5cc97a9b6598c5e5708ca6edc3..a54c3e212bed505ffa0ac052227c0a152d55a41f 100644 (file)
@@ -561,14 +561,6 @@ define LegacyDevice/FRITZ7320
 endef
 LEGACY_DEVICES += FRITZ7320
 
-define Device/GR7000
-  DEVICE_PROFILE := GR7000
-  IMAGE_SIZE := 7808k
-  DEVICE_TITLE := Aztech GR7000
-  DEVICE_PACKAGES := kmod-ltq-deu-ar9 kmod-usb-dwc2 swconfig
-endef
-TARGET_DEVICES += GR7000
-
 define Device/H201L
   DEVICE_PROFILE := H201L
   IMAGE_SIZE := 7808k