odhcp6c: add source routing support
authorSteven Barth <cyrus@openwrt.org>
Sun, 15 Dec 2013 19:10:20 +0000 (19:10 +0000)
committerSteven Barth <cyrus@openwrt.org>
Sun, 15 Dec 2013 19:10:20 +0000 (19:10 +0000)
SVN-Revision: 39058

package/network/ipv6/odhcp6c/Makefile
package/network/ipv6/odhcp6c/files/dhcpv6.script
package/network/ipv6/odhcp6c/files/dhcpv6.sh

index bd794dc8643a2aad9e3c01e63fa18da49f0df239..7d0c48d518faf26077107a9a50d667c41e938fe9 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_VERSION:=2013-10-29
+PKG_VERSION:=2013-12-15
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=60c9e4d5a26f530e89ed6254e8c09380b50fac08
+PKG_SOURCE_VERSION:=be05c0ded0257cbb82857f6d01226ef6de28befe
 PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
 
 include $(INCLUDE_DIR)/package.mk
index 324a823ce9ff62546fe9f1d70d195b8922ff85c5..1d5f521e45f1ee228ea545caf1f08bead4c571e7 100755 (executable)
@@ -64,7 +64,15 @@ setup_interface () {
                entry="${entry#*,}"
                local metric="${entry%%,*}"
 
-               proto_add_ipv6_route "$addr" "$mask" "$gw" "$metric" "$valid"
+               if [ -z "$SOURCE_ROUTING" -o -z "$gw" ]; then
+                       proto_add_ipv6_route "$addr" "$mask" "$gw" "$metric" "$valid"
+               else
+                       proto_add_ipv6_route "$addr" "$mask" "$gw" "$metric" "$valid" "::/128"
+                       for prefix in $PREFIXES; do
+                               local paddr="${prefix%%,*}"
+                               proto_add_ipv6_route "$addr" "$mask" "$gw" "$metric" "$valid" "$paddr"
+                       done
+               fi
        done
 
        proto_send_update "$INTERFACE"
index ab344e1d30446a585eb063782c65265df437b326..0638d28f5f8532cd079d2ba1e29cf2c74bb1e4bc 100755 (executable)
@@ -15,14 +15,15 @@ proto_dhcpv6_init_config() {
        proto_config_add_string "ip6prefix"
        proto_config_add_string "iface_dslite"
        proto_config_add_string "ifaceid"
+       proto_config_add_string "sourcerouting"
 }
 
 proto_dhcpv6_setup() {
        local config="$1"
        local iface="$2"
 
-       local reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite ifaceid
-       json_get_vars reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite ifaceid
+       local reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite ifaceid sourcerouting
+       json_get_vars reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite ifaceid sourcerouting
 
 
        # Configure
@@ -48,6 +49,7 @@ proto_dhcpv6_setup() {
 
        [ -n "$ip6prefix" ] && proto_export "USERPREFIX=$ip6prefix"
        [ -n "$iface_dslite" ] && proto_export "IFACE_DSLITE=$iface_dslite"
+       [ "$sourcerouting" = "1" ] && proto_export "SOURCE_ROUTING=1"
 
        proto_export "INTERFACE=$config"
        proto_run_command "$config" odhcp6c \