ed43f8f0dab77171d523f16770966ccfc68df0f5
[openwrt/staging/chunkeey.git] / toolchain / gcc / Config.in
1 # Choose gcc version.
2
3 choice
4 prompt "GCC compiler Version" if TOOLCHAINOPTS
5 default GCC_VERSION_3_4_6 if LINUX_2_4
6 default GCC_VERSION_4_2_0 if TARGET_magicbox
7 default GCC_VERSION_4_2_3 if TARGET_avr32
8 default GCC_VERSION_4_1_2
9 help
10 Select the version of gcc you wish to use.
11
12 config GCC_VERSION_3_4_6
13 bool "gcc 3.4.6"
14
15 config GCC_VERSION_4_1_2
16 depends !LINUX_2_4
17 bool "gcc 4.1.2"
18
19 config GCC_VERSION_4_2_0
20 depends !LINUX_2_4
21 bool "gcc 4.2.0"
22
23 config GCC_VERSION_4_2_1
24 depends !LINUX_2_4
25 bool "gcc 4.2.1"
26
27 config GCC_VERSION_4_2_2
28 depends !LINUX_2_4
29 bool "gcc 4.2.2"
30
31 config GCC_VERSION_4_2_3
32 depends !LINUX_2_4
33 bool "gcc 4.2.3"
34
35 endchoice
36
37 config EABI_SUPPORT
38 bool
39 depends arm||armeb
40 prompt "Enable EABI support" if TOOLCHAINOPTS
41 default n
42 help
43 Enable ARM EABI support
44
45 config EXTRA_GCC_CONFIG_OPTIONS
46 string
47 prompt "Additional gcc options" if TOOLCHAINOPTS
48 default ""
49 help
50 Any additional gcc options you may want to include....
51
52 config INSTALL_LIBSTDCPP
53 bool
54 prompt "Build/install c++ compiler and libstdc++?" if TOOLCHAINOPTS
55 default y
56 help
57 Build/install c++ compiler and libstdc++?
58
59 config INSTALL_LIBGCJ
60 bool
61 prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
62 default n
63 help
64 Build/install java compiler and GNU classpath ?