toolchain/gcc: add support for gcc-4.3.5
[openwrt/staging/chunkeey.git] / toolchain / gcc / Config.in
1 # Choose gcc version.
2
3 choice
4 prompt "GCC compiler Version" if TOOLCHAINOPTS
5 default GCC_VERSION_3_4_6 if LINUX_2_4
6 default GCC_VERSION_4_2_4 if avr32
7 default GCC_VERSION_4_3_3 if powerpc64
8 default GCC_VERSION_4_3_3 if TARGET_coldfire
9 default GCC_VERSION_4_3_3 if TARGET_etrax
10 default GCC_VERSION_4_3_3_CS if (arm || armeb) && !TARGET_gemini
11 default GCC_VERSION_4_3_3_CS if (mips || mipsel) && !(TARGET_octeon || TARGET_sibyte)
12 default GCC_VERSION_4_3_4 if TARGET_gemini
13 default GCC_VERSION_4_4_1 if ubicom32
14 default GCC_VERSION_4_4_3 if powerpc
15 default GCC_VERSION_4_4_3 if (TARGET_octeon || TARGET_sibyte)
16 default GCC_VERSION_4_1_2
17 help
18 Select the version of gcc you wish to use.
19
20 config GCC_VERSION_3_4_6
21 bool "gcc 3.4.6"
22
23 if !LINUX_2_4
24 config GCC_VERSION_4_1_2
25 bool "gcc 4.1.2"
26
27 config GCC_VERSION_4_2_4
28 bool "gcc 4.2.4"
29
30 config GCC_VERSION_4_3_3
31 bool "gcc 4.3.3"
32
33 config GCC_VERSION_4_3_4
34 bool "gcc 4.3.4"
35
36 config GCC_VERSION_4_3_5
37 bool "gcc 4.3.5"
38
39 config GCC_VERSION_4_4_1
40 bool "gcc 4.4.1"
41
42 config GCC_VERSION_4_4_2
43 bool "gcc 4.4.2"
44
45 config GCC_VERSION_4_4_3
46 bool "gcc 4.4.3"
47
48 config GCC_VERSION_4_5_0
49 bool "gcc 4.5.0"
50
51 config GCC_VERSION_LLVM
52 bool "llvm-gcc 4.2"
53 depends BROKEN
54
55 config GCC_VERSION_4_3_3_CS
56 bool "gcc 4.3.3 with CodeSourcery enhancements"
57
58 config GCC_VERSION_4_4_1_CS
59 bool "gcc 4.4.1 with CodeSourcery enhancements"
60 depends BROKEN
61
62 config GCC_VERSION_4_4_3_CS
63 bool "gcc 4.4.3 with CodeSourcery enhancements"
64 depends BROKEN
65
66 endif
67
68 endchoice
69
70 config GCC_USE_GRAPHITE
71 bool
72 prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
73 depends GCC_VERSION_4_4 || GCC_VERSION_4_5
74
75 config GCC_USE_SYSTEM_PPL_CLOOG
76 bool
77 prompt "Use the system versions of PPL and CLooG"
78 depends GCC_USE_GRAPHITE
79 default n
80
81 config EXTRA_GCC_CONFIG_OPTIONS
82 string
83 prompt "Additional gcc configure options" if TOOLCHAINOPTS
84 default ""
85 help
86 Any additional gcc options you may want to include....
87
88 config SSP_SUPPORT
89 bool
90 depends !GCC_VERSION_3_4_6
91 prompt "Enable Stack-Smashing Protection support" if TOOLCHAINOPTS
92 default n
93 help
94 Enable Stack-Smashing Protection support
95
96 config TLS_SUPPORT
97 bool
98 depends !GCC_VERSION_3_4_6 && UCLIBC_VERSION_NPTL
99 prompt "Enable Thread-local storage (TLS) support" if TOOLCHAINOPTS
100 default n
101 help
102 Enable Thread-local storage support
103
104 config INSTALL_LIBSTDCPP
105 bool
106 prompt "Build/install c++ compiler and libstdc++?" if TOOLCHAINOPTS
107 default y
108 help
109 Build/install c++ compiler and libstdc++?
110
111 config INSTALL_LIBGCJ
112 bool
113 prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
114 default n
115 help
116 Build/install java compiler and GNU classpath ?