toolchain: mark gcc 4.9 as broken, it miscompiles some code especially on ARM
[openwrt/staging/chunkeey.git] / toolchain / gcc / Config.in
1 # Choose gcc version.
2
3 choice
4 prompt "GCC compiler Version" if TOOLCHAINOPTS
5 default GCC_USE_VERSION_4_6_LINARO if TARGET_octeon
6 default GCC_USE_VERSION_4_8_LINARO
7 help
8 Select the version of gcc you wish to use.
9
10 config GCC_USE_VERSION_4_6_LINARO
11 select GCC_VERSION_4_6_LINARO
12 bool "gcc 4.6.x with Linaro enhancements"
13
14 config GCC_USE_VERSION_4_8_LINARO
15 select GCC_VERSION_4_8_LINARO
16 bool "gcc 4.8.x with Linaro enhancements"
17
18 config GCC_USE_VERSION_4_9_LINARO
19 select GCC_VERSION_4_9_LINARO
20 bool "gcc 4.9.x with Linaro enhancements"
21 depends on BROKEN
22
23 endchoice
24
25 config GCC_USE_GRAPHITE
26 bool
27 prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
28
29 config GCC_USE_SYSTEM_PPL_CLOOG
30 bool
31 prompt "Use the system versions of PPL and CLooG"
32 depends on GCC_USE_GRAPHITE
33 default n
34
35 config EXTRA_GCC_CONFIG_OPTIONS
36 string
37 prompt "Additional gcc configure options" if TOOLCHAINOPTS
38 default ""
39 help
40 Any additional gcc options you may want to include....
41
42 config SSP_SUPPORT
43 bool
44 prompt "Enable Stack-Smashing Protection support" if TOOLCHAINOPTS
45 default y
46 help
47 Enable Stack-Smashing Protection support
48
49 config SJLJ_EXCEPTIONS
50 bool
51 prompt "Use setjump()/longjump() exceptions" if TOOLCHAINOPTS
52 default n
53 help
54 Use old setjump()/longjump() exceptions instead of the newer
55 frame unwinding exceptions handling routines. Warning: increases
56 code size and runtime memory usage.
57
58 config INSTALL_LIBGCJ
59 bool
60 prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
61 default n
62 help
63 Build/install java compiler and GNU classpath ?
64
65
66 config INSTALL_GFORTRAN
67 bool
68 prompt "Build/install fortran compiler?" if TOOLCHAINOPTS
69 default n
70 help
71 Build/install GNU fortran compiler ?