add preliminary support for musl
[openwrt/staging/chunkeey.git] / toolchain / gcc / Config.in
1 # Choose gcc version.
2
3 choice
4 prompt "GCC compiler Version" if TOOLCHAINOPTS
5 default GCC_VERSION_4_4_7 if GCC_DEFAULT_VERSION_4_4_7
6 default GCC_VERSION_4_6_LINARO
7 help
8 Select the version of gcc you wish to use.
9
10 config GCC_VERSION_4_4_7
11 bool "gcc 4.4.7"
12 depends (avr32 || ubicom32)
13
14 config GCC_VERSION_4_6_2
15 bool "gcc 4.6.2"
16
17 config GCC_VERSION_4_6_3
18 bool "gcc 4.6.3"
19
20 config GCC_VERSION_4_7_2
21 bool "gcc 4.7.2"
22
23 config GCC_VERSION_4_5_LINARO
24 bool "gcc 4.5.x with Linaro enhancements"
25
26 config GCC_VERSION_4_6_LINARO
27 bool "gcc 4.6.x with Linaro enhancements"
28
29 config GCC_VERSION_4_7_LINARO
30 bool "gcc 4.7.x with Linaro enhancements"
31
32 config GCC_VERSION_LLVM
33 bool "llvm-gcc 4.2"
34 depends BROKEN
35
36 endchoice
37
38 config GCC_USE_GRAPHITE
39 bool
40 prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
41 depends !GCC_VERSION_LLVM
42
43 config GCC_USE_SYSTEM_PPL_CLOOG
44 bool
45 prompt "Use the system versions of PPL and CLooG"
46 depends GCC_USE_GRAPHITE
47 default n
48
49 config EXTRA_GCC_CONFIG_OPTIONS
50 string
51 prompt "Additional gcc configure options" if TOOLCHAINOPTS
52 default ""
53 help
54 Any additional gcc options you may want to include....
55
56 config SSP_SUPPORT
57 bool
58 prompt "Enable Stack-Smashing Protection support" if TOOLCHAINOPTS
59 default n
60 help
61 Enable Stack-Smashing Protection support
62
63 config TLS_SUPPORT
64 bool
65 prompt "Enable Thread-local storage (TLS) support" if TOOLCHAINOPTS
66 default n
67 help
68 Enable Thread-local storage support
69
70 config SJLJ_EXCEPTIONS
71 bool
72 prompt "Use setjump()/longjump() exceptions" if TOOLCHAINOPTS
73 default n
74 help
75 Use old setjump()/longjump() exceptions instead of the newer
76 frame unwinding exceptions handling routines. Warning: increases
77 code size and runtime memory usage.
78
79 config INSTALL_LIBSTDCPP
80 bool
81 prompt "Build/install c++ compiler and libstdc++?" if TOOLCHAINOPTS
82 default y if !USE_MUSL
83 help
84 Build/install c++ compiler and libstdc++?
85
86 config INSTALL_LIBGCJ
87 bool
88 depends on !GCC_VERSION_LLVM
89 prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
90 default n
91 help
92 Build/install java compiler and GNU classpath ?
93
94
95 config INSTALL_GFORTRAN
96 bool
97 prompt "Build/install fortran compiler?" if TOOLCHAINOPTS
98 default n
99 help
100 Build/install GNU fortran compiler ?