toolchain/gcc: use 4.8-linaro by default
[openwrt/staging/chunkeey.git] / toolchain / gcc / Config.in
1 # Choose gcc version.
2
3 choice
4 prompt "GCC compiler Version" if TOOLCHAINOPTS
5 default GCC_USE_VERSION_4_4_7 if avr32
6 default GCC_USE_VERSION_4_8_LINARO
7 help
8 Select the version of gcc you wish to use.
9
10 config GCC_USE_VERSION_4_4_7
11 select GCC_VERSION_4_4_7
12 bool "gcc 4.4.7"
13 depends on avr32
14
15 config GCC_USE_VERSION_4_8_0
16 select GCC_VERSION_4_8_0
17 bool "gcc 4.8.0"
18
19 config GCC_USE_VERSION_4_6_LINARO
20 select GCC_VERSION_4_6_LINARO
21 bool "gcc 4.6.x with Linaro enhancements"
22
23 config GCC_USE_VERSION_4_8_LINARO
24 select GCC_VERSION_4_8_LINARO
25 bool "gcc 4.8.x with Linaro enhancements"
26
27 endchoice
28
29 config GCC_USE_GRAPHITE
30 bool
31 prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
32
33 config GCC_USE_SYSTEM_PPL_CLOOG
34 bool
35 prompt "Use the system versions of PPL and CLooG"
36 depends on GCC_USE_GRAPHITE
37 default n
38
39 config EXTRA_GCC_CONFIG_OPTIONS
40 string
41 prompt "Additional gcc configure options" if TOOLCHAINOPTS
42 default ""
43 help
44 Any additional gcc options you may want to include....
45
46 config SSP_SUPPORT
47 bool
48 prompt "Enable Stack-Smashing Protection support" if TOOLCHAINOPTS
49 default n
50 help
51 Enable Stack-Smashing Protection support
52
53 config SJLJ_EXCEPTIONS
54 bool
55 prompt "Use setjump()/longjump() exceptions" if TOOLCHAINOPTS
56 default n
57 help
58 Use old setjump()/longjump() exceptions instead of the newer
59 frame unwinding exceptions handling routines. Warning: increases
60 code size and runtime memory usage.
61
62 config INSTALL_LIBGCJ
63 bool
64 prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
65 default n
66 help
67 Build/install java compiler and GNU classpath ?
68
69
70 config INSTALL_GFORTRAN
71 bool
72 prompt "Build/install fortran compiler?" if TOOLCHAINOPTS
73 default n
74 help
75 Build/install GNU fortran compiler ?