move EABI config option out of GCC
[openwrt/staging/chunkeey.git] / toolchain / gcc / Config.in
1 # Choose gcc version.
2
3 choice
4 prompt "GCC compiler Version" if TOOLCHAINOPTS
5 default GCC_VERSION_3_4_6 if LINUX_2_4
6 default GCC_VERSION_4_2_4 if TARGET_avr32
7 default GCC_VERSION_4_2_4 if TARGET_ppc40x
8 default GCC_VERSION_4_2_4 if TARGET_ppc44x
9 default GCC_VERSION_4_3_3 if powerpc64
10 default GCC_VERSION_4_3_3 if TARGET_etrax
11 default GCC_VERSION_4_3_3 if TARGET_coldfire
12 default GCC_VERSION_4_4_0 if ubicom32
13 default GCC_VERSION_4_4_1 if TARGET_octeon
14 default GCC_VERSION_4_1_2
15 help
16 Select the version of gcc you wish to use.
17
18 config GCC_VERSION_3_4_6
19 bool "gcc 3.4.6"
20
21 if !LINUX_2_4
22 config GCC_VERSION_4_1_2
23 bool "gcc 4.1.2"
24
25 config GCC_VERSION_4_2_4
26 bool "gcc 4.2.4"
27
28 config GCC_VERSION_4_3_3
29 bool "gcc 4.3.3"
30
31 config GCC_VERSION_4_3_4
32 bool "gcc 4.3.4"
33
34 config GCC_VERSION_4_4_0
35 bool "gcc 4.4.0"
36
37 config GCC_VERSION_4_4_1
38 bool "gcc 4.4.1"
39 endif
40
41 endchoice
42
43 config EXTRA_GCC_CONFIG_OPTIONS
44 string
45 prompt "Additional gcc configure options" if TOOLCHAINOPTS
46 default ""
47 help
48 Any additional gcc options you may want to include....
49
50 config SSP_SUPPORT
51 bool
52 depends !GCC_VERSION_3_4_6
53 prompt "Enable Stack-Smashing Protection support" if TOOLCHAINOPTS
54 default n
55 help
56 Enable Stack-Smashing Protection support
57
58 config INSTALL_LIBSTDCPP
59 bool
60 prompt "Build/install c++ compiler and libstdc++?" if TOOLCHAINOPTS
61 default y
62 help
63 Build/install c++ compiler and libstdc++?
64
65 config INSTALL_LIBGCJ
66 bool
67 prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
68 default n
69 help
70 Build/install java compiler and GNU classpath ?