tools/cmake: update to 3.5.1
[openwrt/staging/chunkeey.git] / tools / cmake / patches / 100-disable_qt_tests.patch
1 --- a/Tests/RunCMake/CMakeLists.txt
2 +++ b/Tests/RunCMake/CMakeLists.txt
3 @@ -217,15 +217,6 @@ add_RunCMake_test(interface_library)
4 add_RunCMake_test(no_install_prefix)
5 add_RunCMake_test(configure_file)
6
7 -find_package(Qt4 QUIET)
8 -find_package(Qt5Core QUIET)
9 -if (QT4_FOUND AND Qt5Core_FOUND AND NOT Qt5Core_VERSION VERSION_LESS 5.1.0)
10 - add_RunCMake_test(IncompatibleQt)
11 -endif()
12 -if (QT4_FOUND)
13 - add_RunCMake_test(ObsoleteQtMacros -DQT_QMAKE_EXECUTABLE:FILEPATH=${QT_QMAKE_EXECUTABLE})
14 -endif()
15 -
16 find_package(PkgConfig QUIET)
17 if(PKG_CONFIG_FOUND)
18 add_RunCMake_test(FindPkgConfig)
19 --- a/Tests/CMakeLists.txt
20 +++ b/Tests/CMakeLists.txt
21 @@ -389,10 +389,6 @@ if(BUILD_TESTING)
22
23 list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
24
25 - if(NOT QT4_FOUND)
26 - find_package(Qt4 QUIET)
27 - endif()
28 -
29 if(QT4_FOUND)
30 # test whether the Qt4 which has been found works, on some machines
31 # which run nightly builds there were errors like "wrong file format"