build system refactoring in preparation for allowing packages to do host-build steps
[openwrt/staging/chunkeey.git] / include / download.mk
index 3866242805c212cd9ba9e346fdc57e149e2f2f68..811c42a3c37e249974b76197e4899d34f17ae7f9 100644 (file)
@@ -5,16 +5,20 @@
 # See /LICENSE for more information.
 #
 
-DOWNLOAD_RDEP:=$(STAMP_PREPARED)
+DOWNLOAD_RDEP:=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
 
 # Try to guess the download method from the URL
 define dl_method 
 $(strip \
   $(if $(2),$(2), \
-    $(if $(filter @GNU/% @KERNEL/% @SF/% ftp://% http://%,$(1)),default, \
+    $(if $(filter @GNOME/% @GNU/% @KERNEL/% @SF/% ftp://% http://%,$(1)),default, \
       $(if $(filter git://%,$(1)),git, \
         $(if $(filter svn://%,$(1)),svn, \
-          unknown \
+          $(if $(filter cvs://%,$(1)),cvs, \
+            $(if $(filter hg://%,$(1)),hg, \
+              unknown \
+           ) \
+         ) \
         ) \
       ) \
     ) \
@@ -22,7 +26,7 @@ $(strip \
 )
 endef
 
-# code for creating tarballs from svn/git checkouts - useful for mirror support
+# code for creating tarballs from cvs/svn/git/hg checkouts - useful for mirror support
 dl_pack/bz2=$(TAR) cfj $(1) $(2)
 dl_pack/gz=$(TAR) cfz $(1) $(2)
 dl_pack/unknown=echo "ERROR: Unknown pack format for file $(1)"; false
@@ -39,19 +43,33 @@ define DownloadMethod/default
 endef
 
 define wrap_mirror
-       @$(if $(CONFIG_LOCALMIRROR),$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x" || ) \
-       ( $(1) ) \
-       $(if $(CONFIG_LOCALMIRROR),, || $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x")
+       $(if $(MIRROR),@$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x" || ( $(1) ),$(1))
 endef
 
+define DownloadMethod/cvs
+       $(call wrap_mirror, \
+               echo "Checking out files from the cvs repository..."; \
+                mkdir -p $(TMP_DIR)/dl && \
+                cd $(TMP_DIR)/dl && \
+                rm -rf $(SUBDIR) && \
+                [ \! -d $(SUBDIR) ] && \
+                cvs -d $(URL) co $(VERSION) $(SUBDIR) && \
+                find $(SUBDIR) -name CVS | xargs rm -rf && \
+                echo "Packing checkout..." && \
+                $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
+                mv $(TMP_DIR)/dl/$(FILE) $(DL_DIR)/; \
+        )
+endef
+
+
 define DownloadMethod/svn
        $(call wrap_mirror, \
-               echo "Checking out files from svn repository..."; \
+               echo "Checking out files from the svn repository..."; \
                mkdir -p $(TMP_DIR)/dl && \
                cd $(TMP_DIR)/dl && \
                rm -rf $(SUBDIR) && \
                [ \! -d $(SUBDIR) ] && \
-               svn co -r$(VERSION) $(URL) $(SUBDIR) && \
+               svn co --non-interactive -r$(VERSION) $(URL) $(SUBDIR) && \
                find $(SUBDIR) -name .svn | xargs rm -rf && \
                echo "Packing checkout..." && \
                $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
@@ -59,8 +77,41 @@ define DownloadMethod/svn
        )
 endef
 
+define DownloadMethod/git
+       $(call wrap_mirror, \
+               echo "Checking out files from the git repository..."; \
+               mkdir -p $(TMP_DIR)/dl && \
+               cd $(TMP_DIR)/dl && \
+               rm -rf $(SUBDIR) && \
+               [ \! -d $(SUBDIR) ] && \
+               git clone $(URL) $(SUBDIR) && \
+               (cd $(SUBDIR) && git checkout $(VERSION)) && \
+               echo "Packing checkout..." && \
+               rm -rf $(SUBDIR)/.git && \
+               $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
+               mv $(TMP_DIR)/dl/$(FILE) $(DL_DIR)/; \
+       )
+endef
+
+define DownloadMethod/hg
+       $(call wrap_mirror, \
+               echo "Checking out files from the hg repository..."; \
+               mkdir -p $(TMP_DIR)/dl && \
+               cd $(TMP_DIR)/dl && \
+               rm -rf $(SUBDIR) && \
+               [ \! -d $(SUBDIR) ] && \
+               hg clone -r $(VERSION) $(URL) $(SUBDIR) && \
+               find $(SUBDIR) -name .hg | xargs rm -rf && \
+               echo "Packing checkout..." && \
+               $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
+               mv $(TMP_DIR)/dl/$(FILE) $(DL_DIR)/; \
+       )
+endef
+
+Validate/cvs=VERSION SUBDIR
 Validate/svn=VERSION SUBDIR
-#Validate/git=VERSION SUBDIR
+Validate/git=VERSION SUBDIR
+Validate/hg=VERSION SUBDIR
 
 define Download/Defaults
   URL:=
@@ -68,6 +119,7 @@ define Download/Defaults
   PROTO:=
   MD5SUM:=
   SUBDIR:=
+  MIRROR:=1
   VERSION:=
 endef