add initial support for the crisarchitecture used on foxboards to openwrt
[openwrt/staging/chunkeey.git] / include / host.mk
index 4a434711c3c8649c259cb3826aacb53fd9547c8d..833aa83a66fb3c75204c6fe74160e4a59d3fbc15 100644 (file)
@@ -9,6 +9,8 @@ include $(TMP_DIR)/.host.mk
 
 export TAR
 
+ifneq ($(__host_inc),1)
+__host_inc:=1
 $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
        @mkdir -p $(TMP_DIR)
        @( \
@@ -26,9 +28,13 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                TAR=`which gtar 2>/dev/null`; \
                [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar 2>/dev/null`; \
                echo "TAR:=$$TAR" >> $@; \
-               ZCAT=`which gzcat 2>/dev/null`; \
-               [ -n "$$ZCAT" -a -x "$$ZCAT" ] || ZCAT=`which zcat 2>/dev/null`; \
-               echo "ZCAT:=$$ZCAT" >> $@; \
                echo "BASH:=$(shell which bash)" >> $@; \
        )
 
+endif
+
+ifeq ($(HOST_OS),Linux)
+  XARGS:=xargs -r
+else
+  XARGS:=xargs
+endif