kernel: bump 5.4 to 5.4.151
[openwrt/staging/chunkeey.git] / include / image-commands.mk
index afb2dde5ba3789247804551bd529e4fa2bce1705..1c9e8c12bb5fa8d9c073230c775e440524dc1f81 100644 (file)
@@ -198,7 +198,7 @@ define Build/elx-header
                        dd bs=20 count=1 conv=sync; \
                echo -ne "$$(printf '%08x' $$(stat -c%s $@) | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
                        dd bs=8 count=1 conv=sync; \
-               echo -ne "$$($(STAGING_DIR_HOST)/bin/mkhash md5 $@ | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
+               echo -ne "$$($(MKHASH) md5 $@ | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
                        dd bs=58 count=1 conv=sync; \
        ) > $(KDIR)/tmp/$(DEVICE_NAME).header
        $(call Build/xor-image,-p $(xor_pattern) -x)
@@ -232,6 +232,7 @@ define Build/fit
                                -i $(KERNEL_BUILD_DIR)/initrd.cpio$(strip $(call Build/initrd_compression)))) \
                -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
                $(if $(DEVICE_FDT_NUM),-n $(DEVICE_FDT_NUM)) \
+               $(if $(DEVICE_DTS_DELIMITER),-l $(DEVICE_DTS_DELIMITER)) \
                $(if $(DEVICE_DTS_OVERLAY),$(foreach dtso,$(DEVICE_DTS_OVERLAY), -O $(dtso):$(KERNEL_BUILD_DIR)/image-$(dtso).dtb)) \
                -c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config-1") \
                -A $(LINUX_KARCH) -v $(LINUX_VERSION)