build: move seama commands to image-commands.mk
[openwrt/staging/chunkeey.git] / include / image-commands.mk
index 65fa36d2beb1c82a4fc757450f67a68185f3dc11..c5b64c751d9cc9ac20537807976f5d32fa0f18b4 100644 (file)
@@ -49,6 +49,18 @@ define Build/eva-image
        mv $@.new $@
 endef
 
+define Build/seama
+       $(STAGING_DIR_HOST)/bin/seama -i $@ \
+               -m "dev=/dev/mtdblock/$(SEAMA_MTDBLOCK)" -m "type=firmware"
+       mv $@.seama $@
+endef
+
+define Build/seama-seal
+       $(STAGING_DIR_HOST)/bin/seama -i $@ -s $@.seama \
+               -m "signature=$(SEAMA_SIGNATURE)"
+       mv $@.seama $@
+endef
+
 define Build/zyxel-ras-image
        let \
                newsize="$(subst k,* 1024,$(RAS_ROOTFS_SIZE))"; \