fix kernel build with quilt
[openwrt/staging/chunkeey.git] / include / kernel.mk
index b2a7476aa017b3d4dbc9c9e457be5c289f7ace32..788e3f2378fe87b9ca78c1fe64bb5073cdc11bf1 100644 (file)
@@ -43,7 +43,9 @@ else
   TESTING:=$(if $(findstring -rc,$(LINUX_VERSION)),/testing,)
   LINUX_SITE:=@KERNEL/linux/kernel/v$(KERNEL)$(TESTING) \
 
-  PKG_BUILD_DIR ?= $(KERNEL_BUILD_DIR)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
+  ifneq ($(TARGET_BUILD),1)
+    PKG_BUILD_DIR ?= $(KERNEL_BUILD_DIR)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
+  endif
 endif
 
 ifneq (,$(findstring uml,$(BOARD)))