build: clean up redundant touching of the package install info file
[openwrt/staging/chunkeey.git] / include / package.mk
index ce1aa256bdf0eaf78c298fcba0f207e6ca9047fc..bf308bb5c076aa8f01eeb8638bdd60103abb273a 100644 (file)
@@ -37,7 +37,6 @@ endif
 
 include $(INCLUDE_DIR)/hardening.mk
 include $(INCLUDE_DIR)/prereq.mk
-include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/unpack.mk
 include $(INCLUDE_DIR)/depends.mk
 
@@ -294,13 +293,13 @@ Build/DistCheck=$(call Build/DistCheck/Default,)
 .PHONY: prepare-package-install
 prepare-package-install:
        @mkdir -p $(PKG_INFO_DIR)
-       @touch $(PKG_INSTALL_STAMP).clean
+       @rm -f $(PKG_INSTALL_STAMP)
        @echo "$(filter-out essential nonshared,$(PKG_FLAGS))" > $(PKG_INSTALL_STAMP).flags
 
 $(PACKAGE_DIR):
        mkdir -p $@
 
-compile: prepare-package-install
+compile:
 .install: .compile
 install: compile