build: switch to Python 3
[openwrt/staging/chunkeey.git] / include / prereq-build.mk
index f7da916f648c5c67f73938308fe2df26177204bb..c52ca719087caed3a7281b4d98cc325997ad28db 100644 (file)
@@ -141,10 +141,17 @@ $(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
 $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
        perl --version | grep "perl.*v5"))
 
-$(eval $(call SetupHostCommand,python,Please install Python 2.x, \
-       python2.7 -V 2>&1 | grep Python, \
-       python2 -V 2>&1 | grep Python, \
-       python -V 2>&1 | grep Python))
+$(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
+       python3.7 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
+       python3.6 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
+       python3.5 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
+       python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
+
+$(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
+       python3.7 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
+       python3.6 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
+       python3.5 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?', \
+       python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
 
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
        git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))