build: fix umask detection bashism
[openwrt/staging/chunkeey.git] / include / prereq-build.mk
index a416a2d2320990ef1888b621691246cf4eea4af1..f7da916f648c5c67f73938308fe2df26177204bb 100644 (file)
@@ -24,7 +24,7 @@ $(eval $(call TestHostCommand,case-sensitive-fs, \
 
 $(eval $(call TestHostCommand,proper-umask, \
        Please build with umask 022 - other values produce broken packages, \
-       umask | grep -xE 00[012][012]))
+       umask | grep -xE 0?0[012][012]))
 
 $(eval $(call SetupHostCommand,gcc, \
        Please install the GNU C Compiler (gcc) 4.8 or later, \