kernel: bump 3.18 to 3.18.136
[openwrt/staging/chunkeey.git] / include / prereq.mk
index 71ca96e8a78476010922929f06e02c2219fe5a54..0f0f2537448f2f314a4b923d0f3fb3f4924f4397 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -62,7 +62,7 @@ define RequireHeader
   define Require/$(1)
     [ -e "$(1)" ]
   endef
-  
+
   $$(eval $$(call Require,$(1),$(2)))
 endef
 
@@ -86,10 +86,12 @@ endef
 # 3+: candidates
 define SetupHostCommand
   define Require/$(1)
+       [ -f "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0; \
        for cmd in $(call QuoteHostCommand,$(3)) $(call QuoteHostCommand,$(4)) \
                   $(call QuoteHostCommand,$(5)) $(call QuoteHostCommand,$(6)) \
                   $(call QuoteHostCommand,$(7)) $(call QuoteHostCommand,$(8)) \
-                          $(call QuoteHostCommand,$(9)); do \
+                  $(call QuoteHostCommand,$(9)) $(call QuoteHostCommand,$(10)) \
+                  $(call QuoteHostCommand,$(11)) $(call QuoteHostCommand,$(12)); do \
                if [ -n "$$$$$$$$cmd" ]; then \
                        bin="$$$$$$$$(PATH="$(subst $(space),:,$(filter-out $(STAGING_DIR_HOST)/%,$(subst :,$(space),$(PATH))))" \
                                which "$$$$$$$${cmd%% *}")"; \