Rename 'refresh' to 'update' and make the new 'refresh' actually refresh all the...
[openwrt/staging/chunkeey.git] / include / prereq.mk
index f0db860269bce1684cf6c2bf6a93f3ed72f659e9..8a08be8e68c9f4d34b0b8085c99ab01602bd21f5 100644 (file)
@@ -27,7 +27,7 @@ define Require
                        echo 'ok.'; \
                else \
                        echo 'failed.'; \
-                       echo -e "$(strip $(2))" >> $(TMP_DIR)/.prereq-error; \
+                       echo -e "$(PKG_NAME): $(strip $(2))" | perl -ne 's/\\\s*/\n/g,print' >> $(TMP_DIR)/.prereq-error; \
                fi
 
     check-$(1): FORCE