add EXTRA_CFLAGS variable support
[openwrt/staging/chunkeey.git] / include / target.mk
index 7f0501e5957a7948b79dbde566effd15dc51b40a..bd3ceb955b7f00d0f76eb6d6305a2d9be5bd5e68 100644 (file)
@@ -7,6 +7,11 @@
 
 include $(TMP_DIR)/.target.mk
 
-$(TMP_DIR)/.target.mk:
-       $(SCRIPT_DIR)/gen_target_mk.pl < $(TMP_DIR)/.targetinfo > $@
+ifeq ($(IB),1)
+$(TMP_DIR)/.target.mk: $(TOPDIR)/.target.mk
+       $(CP) $< $@
+else
+$(TMP_DIR)/.target.mk: $(TMP_DIR)/.targetinfo
+       $(SCRIPT_DIR)/metadata.pl target_mk < $(TMP_DIR)/.targetinfo > $@
+endif