include/toplevel.mk: print warnings/errors to stderr
[openwrt/staging/chunkeey.git] / include / toplevel.mk
index 19ed8cb1d9daa55c90e544c01543753ee5d25e13..0918298b16ede0d95d020f8d57a47d79e3f06a7f 100644 (file)
@@ -148,7 +148,7 @@ prereq:: prepare-tmpinfo .config
                cp .config tmp/.config; \
                ./scripts/config/conf -D tmp/.config -w tmp/.config Config.in > /dev/null 2>&1; \
                if ./scripts/kconfig.pl '>' .config tmp/.config | grep -q CONFIG; then \
-                       echo "WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!"; \
+                       echo "WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!" >&2; \
                fi \
        )
        @+$(ULIMIT_FIX) $(SUBMAKE) -r $@