hostapd: bump PKG_RELEASE
[openwrt/staging/chunkeey.git] / package / Makefile
index e9bed9b6cc174d6c8a1aea94ccc30c975a259127..4fdf4150469434428c7970e3ebce53f050f992a6 100644 (file)
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 curdir:=package
 
+include $(INCLUDE_DIR)/rootfs.mk
+
 -include $(TMP_DIR)/.packagedeps
+$(curdir)/autoremove:=1
 $(curdir)/builddirs:=$(sort $(package-) $(package-y) $(package-m))
-ifeq ($(SDK),1)
-  $(curdir)/builddirs-install:=.
-else
-  $(curdir)/builddirs-default:=. $(sort $(package-y) $(package-m))
-  $(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
-  $(curdir)/builddirs-install:=. $(sort $(package-y))
+$(curdir)/builddirs-default:=. $(sort $(package-y) $(package-m))
+$(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
+ifdef CHECK_ALL
+$(curdir)/builddirs-check:=$($(curdir)/builddirs)
+$(curdir)/builddirs-download:=$($(curdir)/builddirs)
 endif
 ifneq ($(IGNORE_ERRORS),)
-  $(curdir)/builddirs-ignore-compile:= $(if $(filter m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(m))),$(package-m))
+  package-y-filter := $(package-y)
+  package-m-filter := $(filter-out $(package-y),$(package-m))
+  package-n-filter := $(filter-out $(package-y) $(package-m),$(package-))
+  package-ignore-errors := $(filter n m y,$(IGNORE_ERRORS))
+  package-ignore-errors := $(if $(package-ignore-errors),$(package-ignore-errors),n m)
+  package-ignore-subdirs := $(sort $(foreach m,$(package-ignore-errors),$(package-$(m)-filter)))
+  $(curdir)/builddirs-ignore-download := $(package-ignore-subdirs)
+  $(curdir)/builddirs-ignore-compile := $(package-ignore-subdirs)
+  $(curdir)/builddirs-ignore-host-download := $(package-ignore-subdirs)
+  $(curdir)/builddirs-ignore-host-compile := $(package-ignore-subdirs)
 endif
 
-$(curdir)/install:=$(curdir)/install-cleanup
+PACKAGE_INSTALL_FILES:= \
+       $(foreach pkg,$(sort $(package-y)), \
+               $(foreach variant, \
+                       $(if $(strip $(package/$(pkg)/variants)), \
+                               $(package/$(pkg)/variants), \
+                               $(if $(package/$(pkg)/default-variant), \
+                                       $(package/$(pkg)/default-variant), \
+                                       default \
+                               ) \
+                       ), \
+                       $(PKG_INFO_DIR)/$(lastword $(subst /,$(space),$(pkg))).$(variant).install \
+               ) \
+       )
 
 $(curdir)/cleanup: $(TMP_DIR)/.build
-       rm -rf $(TARGET_DIR)
+       rm -rf $(STAGING_DIR_ROOT)
+
+$(curdir)/merge:
+       rm -rf $(PACKAGE_DIR_ALL)
+       mkdir -p $(PACKAGE_DIR_ALL)
+       -$(foreach pdir,$(PACKAGE_SUBDIRS),$(if $(wildcard $(pdir)/*.ipk),ln -s $(pdir)/*.ipk $(PACKAGE_DIR_ALL);))
+
+$(curdir)/merge-index: $(curdir)/merge
+       (cd $(PACKAGE_DIR_ALL) && $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages; )
+
+ifndef SDK
+  $(curdir)/compile: $(curdir)/system/opkg/host/compile
+endif
 
-$(curdir)/rootfs-prepare: $(TMP_DIR)/.build
+$(curdir)/install: $(TMP_DIR)/.build $(curdir)/merge $(if $(CONFIG_TARGET_PER_DEVICE_ROOTFS),$(curdir)/merge-index)
+       - find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
+       rm -rf $(TARGET_DIR) $(TARGET_DIR_ORIG)
+       mkdir -p $(TARGET_DIR)/tmp
+       $(call opkg,$(TARGET_DIR)) install \
+               $(call opkg_package_files,$(shell cat $(PACKAGE_INSTALL_FILES) 2>/dev/null))
+       @for file in $(PACKAGE_INSTALL_FILES); do \
+               [ -s $$file.flags ] || continue; \
+               for flag in `cat $$file.flags`; do \
+                       $(call opkg,$(TARGET_DIR)) flag $$flag `cat $$file`; \
+               done; \
+       done || true
        @-$(MAKE) package/preconfig
-       @if [ -d $(TOPDIR)/files ]; then \
-               $(CP) $(TOPDIR)/files/. $(TARGET_DIR); \
-       fi
-       @mkdir -p $(TARGET_DIR)/etc/rc.d
-       @( \
-               cd $(TARGET_DIR); \
-               for script in ./etc/init.d/*; do \
-                       grep '#!/bin/sh /etc/rc.common' $$script >/dev/null || continue; \
-                       IPKG_INSTROOT=$(TARGET_DIR) $$(which bash) ./etc/rc.common $$script enable; \
-               done || true \
-       )
-       @-find $(TARGET_DIR) -name CVS   | $(XARGS) rm -rf
-       @-find $(TARGET_DIR) -name .svn  | $(XARGS) rm -rf
-       @-find $(TARGET_DIR) -name '.#*' | $(XARGS) rm -f
-       $(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/ipkg)
+
+       $(CP) $(TARGET_DIR) $(TARGET_DIR_ORIG)
+
+       $(call prepare_rootfs,$(TARGET_DIR))
 
 $(curdir)/index: FORCE
-       @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
-               gzip -9c Packages > Packages.gz \
-       )
+       @echo Generating package index...
+       @for d in $(PACKAGE_SUBDIRS); do ( \
+               mkdir -p $$d; \
+               cd $$d || continue; \
+               $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages.manifest; \
+               grep -vE '^(Maintainer|LicenseFiles|Source|Require)' Packages.manifest > Packages && \
+                       gzip -9nc Packages > Packages.gz; \
+       ); done
+ifdef CONFIG_SIGNED_PACKAGES
+       @echo Signing package index...
+       @for d in $(PACKAGE_SUBDIRS); do ( \
+               [ -d $$d ] && \
+                       cd $$d || continue; \
+               $(STAGING_DIR_HOST)/bin/usign -S -m Packages -s $(BUILD_KEY); \
+       ); done
+endif
+
+$(curdir)/preconfig:
 
 $(curdir)/flags-install:= -j1
 
@@ -55,6 +104,6 @@ $(eval $(call stampfile,$(curdir),package,prereq,.config))
 $(eval $(call stampfile,$(curdir),package,cleanup,$(TMP_DIR)/.build))
 $(eval $(call stampfile,$(curdir),package,compile,$(TMP_DIR)/.build))
 $(eval $(call stampfile,$(curdir),package,install,$(TMP_DIR)/.build))
-$(eval $(call stampfile,$(curdir),package,rootfs-prepare,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,check,$(TMP_DIR)/.build))
 
 $(eval $(call subdir,$(curdir)))