madwifi: fix a crash in ff handling
[openwrt/staging/chunkeey.git] / package / Makefile
index 9a641881a353f98c709fcbda55911775a0297e84..64c78de5e7e0831996c9c24158c3393c0fdc0a2d 100644 (file)
@@ -51,6 +51,7 @@ install:
        @if [ -d $(TOPDIR)/files ]; then \
                $(CP) $(TOPDIR)/files/. $(BUILD_DIR)/root; \
        fi
+       @mkdir -p $(BUILD_DIR)/root/etc/rc.d
        @( \
                cd $(BUILD_DIR)/root; \
                for script in ./etc/init.d/*; do \
@@ -58,6 +59,9 @@ install:
                        IPKG_INSTROOT=$(BUILD_DIR)/root $(which bash) ./etc/rc.common $$script enable; \
                done || true \
        )
+       @-find $(BUILD_DIR)/root -name CVS   | $(XARGS) rm -rf
+       @-find $(BUILD_DIR)/root -name .svn  | $(XARGS) rm -rf
+       @-find $(BUILD_DIR)/root -name '.#*' | $(XARGS) rm -f
 
 index: $(PACKAGE_DIR)/Packages