madwifi: fix a crash in ff handling
[openwrt/staging/chunkeey.git] / package / Makefile
index f5ff8563f38b46da4e2a71fd5601b74040f12c54..64c78de5e7e0831996c9c24158c3393c0fdc0a2d 100644 (file)
@@ -26,9 +26,9 @@ ifeq ($(QUIET),1)
 %-compile %-install: FORCE
        $(MAKE) -C $* $(patsubst $*-%,%,$@) || { $(call MESSAGE, "*** $* $(patsubst $*-%,%,$@) failed"); false; }
 
-%-prereq %-download %-clean: FORCE
+%-prepare %-prereq %-download %-clean: FORCE
 else
-%-prereq %-download %-clean %-compile %-install: FORCE
+%-prepare %-prereq %-download %-clean %-compile %-install: FORCE
 endif
        $(MAKE) -C $* $(patsubst $*-%,%,$@)
 
@@ -51,6 +51,7 @@ install:
        @if [ -d $(TOPDIR)/files ]; then \
                $(CP) $(TOPDIR)/files/. $(BUILD_DIR)/root; \
        fi
+       @mkdir -p $(BUILD_DIR)/root/etc/rc.d
        @( \
                cd $(BUILD_DIR)/root; \
                for script in ./etc/init.d/*; do \
@@ -58,6 +59,9 @@ install:
                        IPKG_INSTROOT=$(BUILD_DIR)/root $(which bash) ./etc/rc.common $$script enable; \
                done || true \
        )
+       @-find $(BUILD_DIR)/root -name CVS   | $(XARGS) rm -rf
+       @-find $(BUILD_DIR)/root -name .svn  | $(XARGS) rm -rf
+       @-find $(BUILD_DIR)/root -name '.#*' | $(XARGS) rm -f
 
 index: $(PACKAGE_DIR)/Packages