Rename 'refresh' to 'update' and make the new 'refresh' actually refresh all the...
[openwrt/staging/chunkeey.git] / package / Makefile
index 64c78de5e7e0831996c9c24158c3393c0fdc0a2d..94241dbc3d860c5d875c22ea47789377cf1f7753 100644 (file)
@@ -32,6 +32,10 @@ else
 endif
        $(MAKE) -C $* $(patsubst $*-%,%,$@)
 
+%-refresh %-update:
+       -$(MAKE) -C $* $(patsubst $*-%,%,$@)
+
+
 # .IGNORE: $(COMPILE_PACKAGES) 
 
 $(TMP_DIR)/.packagedeps: $(TMP_DIR)/.packageinfo
@@ -42,6 +46,9 @@ clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))
 prereq: $(PREREQ_PACKAGES)
 download: $(DOWNLOAD_PACKAGES)
 compile: $(COMPILE_PACKAGES)
+ifneq ($(QUILT),)
+  refresh: $(patsubst %,%-refresh,$(package-y) $(package-m) $(package-))
+endif
 
 install-targets: $(INSTALL_PACKAGES)
 install: