base-files: properly escape strings for version info
[openwrt/staging/chunkeey.git] / package / base-files / Makefile
index 3635a564781700408f8509b5b3ca8a4ab33e461b..10724b3eac00ffac450d951c27026562d01625aa 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2013 OpenWrt.org
+# Copyright (C) 2007-2014 OpenWrt.org
 # Copyright (C) 2010 Vertical Communications
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -7,15 +7,14 @@
 #
 
 include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=141
+PKG_RELEASE:=155
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
-PKG_CONFIG_DEPENDS:=CONFIG_PROCD_INIT
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,7 +28,7 @@ endif
 define Package/base-files
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+netifd +libc +procd
+  DEPENDS:=+netifd +libc +procd +jsonfilter
   TITLE:=Base filesystem for OpenWrt
   URL:=http://openwrt.org/
   VERSION:=$(PKG_RELEASE)-$(REVISION)
@@ -56,12 +55,6 @@ define Package/base-files/description
  This package contains a base filesystem and system scripts for OpenWrt.
 endef
 
-define Package/base-files/config
-config PROCD_INIT
-       bool "Use procd as the init process"
-       default n
-endef
-
 ifneq ($(CONFIG_PREINITOPT),)
 define ImageConfigOptions
        mkdir -p $(1)/lib/preinit
@@ -117,8 +110,11 @@ define Package/base-files/install
 
        $(VERSION_SED) \
                $(1)/etc/banner \
-               $(1)/etc/openwrt_version \
-               $(1)/etc/openwrt_release
+               $(1)/etc/openwrt_version
+
+       $(VERSION_SED_SCRIPT) \
+               $(1)/etc/openwrt_release \
+               $(1)/etc/device_info
 
        mkdir -p $(1)/CONTROL
        mkdir -p $(1)/dev