uboot-at91: fix build after fpu activation
[openwrt/staging/chunkeey.git] / package / boot / uboot-at91 / Makefile
index 7c420f1262b02ad59695377cc5f7d3358f33aa41..268b254206efa4a6b02a1a96d10a7400e6de9bd6 100644 (file)
@@ -88,7 +88,7 @@ UBOOT_TARGETS := \
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                CROSS_COMPILE=$(TARGET_CROSS) \
-               KCFLAGS="$(filter-out -fstack-protector, $(TARGET_CFLAGS))"
+               KCFLAGS="$(filter-out -fstack-protector -mfloat-abi=hard, $(TARGET_CFLAGS)) -mfloat-abi=soft" 
 endef
 
 $(eval $(call BuildPackage/U-Boot))