package/busybox: fix sed issue with gcc-4.5.0 (closes #7566)
[openwrt/staging/chunkeey.git] / package / busybox / Makefile
index 3b93a0575d4063cec3b5a08663e82224c618149e..128a0dea180f5a1cbe1dbccc303c19698608f16f 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
-PKG_VERSION:=1.16.1
-PKG_RELEASE:=5
+PKG_VERSION:=1.16.2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
                http://distfiles.gentoo.org/distfiles/
-PKG_MD5SUM:=319486ec65078d07fde26eb620fecde7
+PKG_MD5SUM:=2ba980f720a5bdce4ec05423519acc35
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -60,6 +60,10 @@ ifdef CONFIG_GCC_VERSION_LLVM
   TARGET_CFLAGS += -fnested-functions
 endif
 
+ifdef CONFIG_GCC_VERSION_4_5_0
+  TARGET_CFLAGS += -fno-tree-pta
+endif
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \