hotplug2: add a missing cflag, allow hotplug events that are not 'add'
[openwrt/staging/chunkeey.git] / package / hotplug2 / Makefile
index bf7c8c6b090ae51bdddb8ee926a3c1e65c7a5b6b..c696f09f5bc536b2e50c89ff2243f3ef247f4da8 100644 (file)
@@ -29,7 +29,7 @@ define Package/hotplug2/description
 Hotplug2 is a trivial replacement of some of the UDev functionality
 in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
 endef
-MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS)"
+MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) -DHAVE_RULES"
 
 define Package/hotplug2/install
        $(INSTALL_DIR) $(1)/etc