Patch to work arounf flex issues with newer version of flex with some distros.
[openwrt/staging/chunkeey.git] / package / iproute2 / Makefile
index 645d0349f496e584c1e546d279e180cc021ce6d3..600c7734cb81cd6acf4a8321e0f51dbd98eac85a 100644 (file)
@@ -15,9 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://developer.osdl.org/dev/iproute2/download/
 PKG_MD5SUM:=04f57a6d366d36426d276178b600f5c5
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://developer.osdl.org/dev/iproute2/download/
 PKG_MD5SUM:=04f57a6d366d36426d276178b600f5c5
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/iproute2-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -66,3 +63,7 @@ endef
 
 $(eval $(call BuildPackage,ip))
 $(eval $(call BuildPackage,tc))
 
 $(eval $(call BuildPackage,ip))
 $(eval $(call BuildPackage,tc))
+
+$(eval $(call RequireCommand,bison, \
+       $(PKG_NAME) requires GNU bison. \
+))