kernel: wpan: mrf24j40 depends on regmap-spi
[openwrt/staging/chunkeey.git] / package / kernel / linux / modules / pcmcia.mk
index 2bf53e5e6018dceedd5f80ba394b5c69a4cabd7b..51668facf075e2d0af928ebfcc842fe6e14cff24 100644 (file)
@@ -33,18 +33,12 @@ define KernelPackage/pcmcia-rsrc
   TITLE:=PCMCIA resource support
   DEPENDS:=kmod-pcmcia-core
   KCONFIG:=CONFIG_PCCARD_NONSTATIC=y
-# For Linux 2.6.35+
-ifneq ($(wildcard $(LINUX_DIR)/drivers/pcmcia/pcmcia_rsrc.ko),)
   FILES:=$(LINUX_DIR)/drivers/pcmcia/pcmcia_rsrc.ko
   AUTOLOAD:=$(call AutoLoad,26,pcmcia_rsrc)
-else
-  FILES:=$(LINUX_DIR)/drivers/pcmcia/rsrc_nonstatic.ko
-  AUTOLOAD:=$(call AutoLoad,26,rsrc_nonstatic)
-endif
 endef
 
 define KernelPackage/pcmcia-rsrc/description
 Kernel support for PCMCIA resource allocation
+ Kernel support for PCMCIA resource allocation
 endef
 
 $(eval $(call KernelPackage,pcmcia-rsrc))