kernel: wpan: mrf24j40 depends on regmap-spi
[openwrt/staging/chunkeey.git] / package / kernel / linux / modules / pcmcia.mk
index cac727719c380a47cd68000ebe938dafa48aac78..51668facf075e2d0af928ebfcc842fe6e14cff24 100644 (file)
@@ -33,18 +33,12 @@ define KernelPackage/pcmcia-rsrc
   TITLE:=PCMCIA resource support
   DEPENDS:=kmod-pcmcia-core
   KCONFIG:=CONFIG_PCCARD_NONSTATIC=y
-# For Linux 2.6.35+
-ifneq ($(wildcard $(LINUX_DIR)/drivers/pcmcia/pcmcia_rsrc.ko),)
   FILES:=$(LINUX_DIR)/drivers/pcmcia/pcmcia_rsrc.ko
   AUTOLOAD:=$(call AutoLoad,26,pcmcia_rsrc)
-else
-  FILES:=$(LINUX_DIR)/drivers/pcmcia/rsrc_nonstatic.ko
-  AUTOLOAD:=$(call AutoLoad,26,rsrc_nonstatic)
-endif
 endef
 
 define KernelPackage/pcmcia-rsrc/description
 Kernel support for PCMCIA resource allocation
+ Kernel support for PCMCIA resource allocation
 endef
 
 $(eval $(call KernelPackage,pcmcia-rsrc))
@@ -65,7 +59,7 @@ $(eval $(call KernelPackage,pcmcia-yenta))
 define KernelPackage/pcmcia-serial
   SUBMENU:=$(PCMCIA_MENU)
   TITLE:=Serial devices support
-  DEPENDS:=kmod-pcmcia-core
+  DEPENDS:=kmod-pcmcia-core +kmod-serial-8250
   KCONFIG:= \
        CONFIG_PCMCIA_SERIAL_CS \
        CONFIG_SERIAL_8250_CS