kernel: remove kmod-input-core just for some x86 profiles.
[openwrt/staging/chunkeey.git] / package / kernel / modules / 001-depends.mk
index 602775c0157a5a0e0ac187005914fd84b17bc7c1..238799e2e54c6d4dcd469598e203d8f36e187986 100644 (file)
@@ -27,11 +27,11 @@ endef
 
 
 define SetDepends/input
-  DEPENDS:= @!TARGET_x86
+  DEPENDS:= @!(TARGET_x86_generic||TARGET_x86_kvm_guest)
 endef
 
 define AddDepends/input
-  DEPENDS+= +!TARGET_x86:kmod-input-core $(1)
+  DEPENDS+= +!(TARGET_x86_generic||TARGET_x86_kvm_guest):kmod-input-core $(1)
 endef