openssl: update to version 1.0.2k
[openwrt/staging/chunkeey.git] / package / libs / openssl / patches / 200-parallel_build.patch
index edb201a45806e16246e163edde04bc00422d6527..f1d9f0705194c27a31a283da0b7728fefa576fda 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.org
 +++ b/Makefile.org
-@@ -280,17 +280,17 @@ build_libcrypto: build_crypto build_engi
+@@ -282,17 +282,17 @@ build_libcrypto: build_crypto build_engi
  build_libssl: build_ssl libssl.pc
  
  build_crypto:
@@ -24,7 +24,7 @@
  
  all_testapps: build_libs build_testapps
  build_testapps:
-@@ -462,7 +462,7 @@ update: errors stacks util/libeay.num ut
+@@ -465,7 +465,7 @@ update: errors stacks util/libeay.num ut
        @set -e; target=update; $(RECURSIVE_BUILD_CMD)
  
  depend:
@@ -34,8 +34,8 @@
  lint:
        @set -e; target=lint; $(RECURSIVE_BUILD_CMD)
 @@ -527,9 +527,9 @@ dist:
- dist_pem_h:
-       (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
+       @$(MAKE) SDIRS='$(SDIRS)' clean
+       @$(MAKE) TAR='$(TAR)' TARFLAGS='$(TARFLAGS)' $(DISTTARVARS) tar
  
 -install: all install_sw
 +install: install_sw
        ctags $(SRC)
 --- a/test/Makefile
 +++ b/test/Makefile
-@@ -138,7 +138,7 @@ install:
+@@ -144,7 +144,7 @@ install:
  tags:
        ctags $(SRC)
  
  
  apps:
        @(cd ..; $(MAKE) DIRS=apps all)
-@@ -549,7 +549,7 @@ $(CLIENTHELLOTEST)$(EXE_EXT): $(CLIENTHE
+@@ -577,7 +577,7 @@ $(DTLSTEST)$(EXE_EXT): $(DTLSTEST).o ssl
  #     fi
  
  dummytest$(EXE_EXT): dummytest.o $(DLIBCRYPTO)