6in4: use uclient-fetch instead of wget/curl
[openwrt/staging/chunkeey.git] / package / network / ipv6 / 6in4 / Makefile
index fcb0a7e75615b6fc2b4b347166254237b5b58b7d..5d9355fa540cdf66836165bf7905db3c2046f87d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2012 OpenWrt.org
+# Copyright (C) 2010-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,15 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=12
+PKG_VERSION:=23
 PKG_RELEASE:=1
+PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/6in4
-  SECTION:=ipv6
-  CATEGORY:=IPv6
-  DEPENDS:=+kmod-ipv6 +kmod-sit
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=@IPV6 +kmod-sit +uclient-fetch
   TITLE:=IPv6-in-IPv4 configuration support
   MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
   PKGARCH:=all