odhcp6c: correctly handle renew-replies with short lease times
[openwrt/staging/chunkeey.git] / package / network / ipv6 / odhcp6c / Makefile
index a0f5bbe6c769ce6996ac2ba2d533d5dd7b1590cf..b2a4e89bc0b3c2ac08b15c183c14a37f2d0a8812 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2012-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,15 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_VERSION:=2014-05-23
+PKG_VERSION:=2014-12-10
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
+PKG_SOURCE_URL:=https://github.com/sbyx/odhcp6c.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=74b94c1442ec0897c1f90a314838594a5d42bb87
+PKG_SOURCE_VERSION:=722226c4f1d45c8bf4ac9189523738abcf7d648f
 PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
+PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
@@ -29,10 +30,6 @@ ifneq ($(CONFIG_PACKAGE_odhcp6c_ext_cer_id),0)
   CMAKE_OPTIONS += -DEXT_CER_ID=$(CONFIG_PACKAGE_odhcp6c_ext_cer_id)
 endif
 
-ifneq ($(CONFIG_PACKAGE_odhcp6c_ext_s46),0)
-  CMAKE_OPTIONS += -DEXT_S46=$(CONFIG_PACKAGE_odhcp6c_ext_s46)
-endif
-
 define Package/odhcp6c
   SECTION:=net
   CATEGORY:=Network
@@ -50,11 +47,6 @@ define Package/odhcp6c/config
     int "CER-ID Extension ID (0 = disabled)"
     depends on PACKAGE_odhcp6c
     default 0
-
-  config PACKAGE_odhcp6c_ext_s46
-    int "Softwire MAP Extension ID (0 = disabled)"
-    depends on PACKAGE_odhcp6c
-    default 0
 endef
 
 define Package/odhcp6c/install