odhcp6c: add route-workaround for broken IPv6-ISPs
[openwrt/staging/chunkeey.git] / package / network / ipv6 / odhcp6c / Makefile
index 709746f6071335f9b29a7aa91ba040ada6ec2a88..c7b16319c35879dd7b1a75c4298eae7d25e212cb 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2012-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_VERSION:=2014-02-05
+PKG_VERSION:=2014-10-06
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=db2915f095db17cb10bf67d5b3bf67f891d45625
+PKG_SOURCE_VERSION:=d6fe99f6d03873e7a670c9b6f26fa03b219422f5
 PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
 
 include $(INCLUDE_DIR)/package.mk
@@ -25,6 +25,10 @@ ifneq ($(CONFIG_PACKAGE_odhcp6c_ext_prefix_class),0)
   CMAKE_OPTIONS += -DEXT_PREFIX_CLASS=$(CONFIG_PACKAGE_odhcp6c_ext_prefix_class)
 endif
 
+ifneq ($(CONFIG_PACKAGE_odhcp6c_ext_cer_id),0)
+  CMAKE_OPTIONS += -DEXT_CER_ID=$(CONFIG_PACKAGE_odhcp6c_ext_cer_id)
+endif
+
 define Package/odhcp6c
   SECTION:=net
   CATEGORY:=Network
@@ -37,6 +41,11 @@ define Package/odhcp6c/config
     int "Prefix Class Extension ID (0 = disabled)"
     depends on PACKAGE_odhcp6c
     default 0
+
+  config PACKAGE_odhcp6c_ext_cer_id
+    int "CER-ID Extension ID (0 = disabled)"
+    depends on PACKAGE_odhcp6c
+    default 0
 endef
 
 define Package/odhcp6c/install