hostapd: Fix wps button hotplug script to handle multiple radios
[openwrt/staging/chunkeey.git] / package / network / services / dropbear / Makefile
index cd5b36825612835e15e36c585171551e5db1e7bb..12a836be37da9f323559b1a7b77aa4689d8a2c12 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,19 +8,22 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
-PKG_VERSION:=2011.54
+PKG_VERSION:=2014.65
 PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        http://matt.ucc.asn.au/dropbear/releases/ \
-       http://www.mirrors.wiretapped.net/security/cryptography/apps/ssh/dropbear/
-PKG_MD5SUM:=c627ffe09570fad7aa94d8eac2b9320c
+       https://dropbear.nl/mirror/releases/
+PKG_MD5SUM:=1918604238817385a156840fa2c39490
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE
 
 PKG_BUILD_PARALLEL:=1
+PKG_USE_MIPS16:=0
+
+PKG_CONFIG_DEPENDS:=CONFIG_DROPBEAR_ECC
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,6 +31,10 @@ define Package/dropbear/Default
   URL:=http://matt.ucc.asn.au/dropbear/
 endef
 
+define Package/dropbear/config
+       source "$(SOURCE)/Config.in"
+endef
+
 define Package/dropbear
   $(call Package/dropbear/Default)
   SECTION:=net
@@ -53,7 +60,6 @@ define Package/dropbearconvert
 endef
 
 CONFIGURE_ARGS += \
-       --with-shared \
        --disable-pam \
        --enable-openpty \
        --enable-syslog \
@@ -73,20 +79,27 @@ TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections
 TARGET_LDFLAGS += -Wl,--gc-sections
 
 define Build/Configure
-       $(SED) 's,^/\* #define PKG_MULTI.*,#define PKG_MULTI,g' $(PKG_BUILD_DIR)/options.h
-       $(SED) 's,^#define DO_HOST_LOOKUP,/* & */,g' $(PKG_BUILD_DIR)/options.h
-       $(call Build/Configure/Default)
+       $(Build/Configure/Default)
+
+       # Enforce that all replacements are made, otherwise options.h has changed
+       # format and this logic is broken.
+       for OPTION in DROPBEAR_ECDSA DROPBEAR_ECDH DROPBEAR_CURVE25519; do \
+         awk 'BEGIN { rc = 1 } \
+              /'$$$$OPTION'/ { $$$$0 = "$(if $(CONFIG_DROPBEAR_ECC),,// )#define '$$$$OPTION'"; rc = 0 } \
+              { print } \
+              END { exit(rc) }' $(PKG_BUILD_DIR)/options.h \
+              >$(PKG_BUILD_DIR)/options.h.new && \
+         mv $(PKG_BUILD_DIR)/options.h.new $(PKG_BUILD_DIR)/options.h || exit 1; \
+       done
 endef
 
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               LD="$(TARGET_CC)" \
                PROGRAMS="dropbear dbclient dropbearkey scp" \
                MULTI=1 SCPPROGRESS=1
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               LD="$(TARGET_CC)" \
                PROGRAMS="dropbearconvert"
 endef
 
@@ -94,10 +107,10 @@ define Package/dropbear/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/dropbearmulti $(1)/usr/sbin/dropbear
        $(INSTALL_DIR) $(1)/usr/bin
-       ln -sf ../sbin/dropbear $(1)/usr/bin/scp
-       ln -sf ../sbin/dropbear $(1)/usr/bin/ssh
-       ln -sf ../sbin/dropbear $(1)/usr/bin/dbclient
-       ln -sf ../sbin/dropbear $(1)/usr/bin/dropbearkey
+       $(LN) ../sbin/dropbear $(1)/usr/bin/scp
+       $(LN) ../sbin/dropbear $(1)/usr/bin/ssh
+       $(LN) ../sbin/dropbear $(1)/usr/bin/dbclient
+       $(LN) ../sbin/dropbear $(1)/usr/bin/dropbearkey
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/dropbear.config $(1)/etc/config/dropbear
        $(INSTALL_DIR) $(1)/etc/init.d