odhcpd: minor fixes
[openwrt/staging/chunkeey.git] / package / network / services / odhcpd / Makefile
index 3dfeb1ca16e2c5f9f9e00267426f2b0581308a3d..635a2511233cd215b1e0d0946b4a00934932e192 100644 (file)
@@ -8,25 +8,32 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcpd
-PKG_VERSION:=2014-03-20
+PKG_VERSION:=2015-04-21
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=git://github.com/sbyx/odhcpd.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=d8cfeab6d37b470a33eeb0fac34934442f890f20
+PKG_SOURCE_VERSION:=4fda796497a0d7814cfe100a1b0f09955f9b24ce
 
 PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
+PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
 CMAKE_OPTIONS += -DUBUS=1
+
 ifneq ($(CONFIG_PACKAGE_odhcpd_ext_prefix_class),0)
   CMAKE_OPTIONS += -DEXT_PREFIX_CLASS=$(CONFIG_PACKAGE_odhcpd_ext_prefix_class)
 endif
 
+ifneq ($(CONFIG_PACKAGE_odhcpd_ext_cer_id),0)
+  CMAKE_OPTIONS += -DEXT_CER_ID=$(CONFIG_PACKAGE_odhcpd_ext_cer_id)
+endif
+
+
 define Package/odhcpd
   SECTION:=net
   CATEGORY:=Network
@@ -39,6 +46,10 @@ define Package/odhcpd/config
     int "Prefix Class Extension ID (0 = disabled)"
     depends on PACKAGE_odhcpd
     default 0
+  config PACKAGE_odhcpd_ext_cer_id
+    int "CER-ID Extension ID (0 = disabled)"
+    depends on PACKAGE_odhcpd
+    default 0
 endef
 
 define Package/odhcpd/description