ppp: compile with LTO enabled
[openwrt/staging/chunkeey.git] / package / network / services / ppp / Makefile
index beeaa53c220c76ce9d875cd0ff2700186ab9654c..60c07565f3bd1749f086e940c5d9ffe545c107e3 100644 (file)
@@ -189,8 +189,8 @@ $(call Build/Configure/Default,, \
                $(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux/
 endef
 
-TARGET_CFLAGS += -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
+TARGET_CFLAGS += -ffunction-sections -fdata-sections -flto
+TARGET_LDFLAGS += -Wl,--gc-sections -flto -fuse-linker-plugin
 
 MAKE_FLAGS += COPTS="$(TARGET_CFLAGS)" \
                PRECOMPILED_FILTER=1 \