curl: add flags to allow gc-sections to strip out unused code
[openwrt/staging/chunkeey.git] / package / network / utils / curl / Makefile
index 319c0b710d2b4ead9492ab2bd6cb5c61c2fd7870..af38ed4aed662f4ceaa1d7087606e3b9dd82f313 100644 (file)
@@ -99,8 +99,9 @@ define Package/libcurl/config
   source "$(SOURCE)/Config.in"
 endef
 
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) -ffunction-sections -fdata-sections
 TARGET_CPPFLAGS += $(if $(CONFIG_LIBCURL_NTLM),,-DCURL_DISABLE_NTLM)
+TARGET_LDFLAGS += -Wl,--gc-sections
 
 CONFIGURE_ARGS += \
        --disable-debug \