iproute2: bump version from 3.16.0 to 3.17.0
[openwrt/staging/chunkeey.git] / package / network / utils / iproute2 / Makefile
index 558855ff4cdb8317fc961bd527b55792d8f4813d..9aea05e80da08c0238c417873bbdf71652a87abc 100644 (file)
@@ -8,13 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=3.15.0
+PKG_VERSION:=3.17.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
-PKG_MD5SUM:=5b1711c9d16071959052e369a2682d77
+PKG_MD5SUM:=b741a02c6dda5818d18011d572874493
 PKG_BUILD_PARALLEL:=1
+PKG_LICENSE:=GPL-2.0
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -31,7 +32,11 @@ define Package/iproute2/Default
   VARIANT:=$(1)
 endef
 
-Package/ip=$(call Package/iproute2/Default,tiny,Minimal)
+define Package/ip
+$(call Package/iproute2/Default,tiny,Minimal)
+  CONFLICTS:=ip-full
+endef
+
 Package/ip-full=$(call Package/iproute2/Default,full,Full)
 
 define Package/ip/conffiles
@@ -77,6 +82,9 @@ ifdef CONFIG_USE_EGLIBC
     TARGET_CFLAGS += -DHAVE_SETNS
   endif
 endif
+ifdef CONFIG_USE_MUSL
+  TARGET_CFLAGS += -DHAVE_SETNS
+endif
 
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
 
@@ -86,7 +94,7 @@ MAKE_FLAGS += \
        SHARED_LIBS="" \
        LDFLAGS="-Wl,--gc-sections" \
        IP_CONFIG_TINY=$(IP_CONFIG_TINY) \
-       FPIC=""
+       FPIC="$(FPIC)"
 
 define Build/Compile
        +$(MAKE_VARS) $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) $(MAKE_FLAGS)