nftables: bump to latest and enable debugging
[openwrt/staging/chunkeey.git] / package / network / utils / nftables / Makefile
index 3b33a1a0a60cb0330dca65885e83fac2896be1d2..5816aa0f9f839d5569ad9282f4302658f9ee9b28 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2014 OpenWrt.org
+# Copyright (C) 2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,24 +7,24 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nftables
-PKG_VERSION:=0.3+2014-09-30
+PKG_VERSION:=0.4+2015-01-12
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=git://git.netfilter.org/nftables
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=36c8a131af6217579da582bc320e16171df0f3af
+PKG_SOURCE_VERSION:=b17e27f472adc2e82582d90df0111d5b95c8afe0
 PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
+PKG_LICENSE:=GPL-2.0
 
 PKG_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/package.mk
 
 CONFIGURE_ARGS += \
-        --disable-debug \
-        --without-libgmp \
-        --without-libreadline \
+        --with-mini-gmp \
+        --without-cli \
 
 define Package/nftables
   SECTION:=net