procd: fix serial console login (#18278)
[openwrt/staging/chunkeey.git] / package / system / procd / Makefile
index 4d1f7b336f11e87ab5b7d8369a1333576ff12984..2576734fd7c4b71ec1ebfd1cbd4d47ea536e650a 100644 (file)
@@ -1,18 +1,25 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_VERSION:=2014-06-11
+PKG_VERSION:=2014-11-04
 
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=efc491fd9345c38054ce96503c3bf846a19e9260
+PKG_SOURCE_VERSION:=44803f0b48e6b0bbc56b1f9f8c2ea9c8e1003302
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
-PKG_LICENSE:=GPLv2
+PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=
 
 PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
@@ -33,9 +40,26 @@ define Package/procd-nand
   SECTION:=utils
   CATEGORY:=Utilities
   DEPENDS:=@NAND_SUPPORT +ubi-utils
-  TITLE:=OpenWrt system process manager
+  TITLE:=OpenWrt sysupgrade nand helper
 endef
 
+define Package/procd/config
+menu "Configuration"
+       depends on PACKAGE_procd
+
+config PROCD_SHOW_BOOT
+       bool
+       default n
+       prompt "Print the shutdown to the console as well as logging it to syslog"
+endmenu
+endef
+
+PKG_CONFIG_DEPENDS:= PROCD_SHOW_BOOT
+
+ifeq ($(CONFIG_PACKAGE_PROCD_SHOW_BOOT),y)
+  CMAKE_OPTIONS += -DSHOW_BOOT_ON_CONSOLE
+endif
+
 define Package/procd/install
        $(INSTALL_DIR) $(1)/sbin $(1)/etc $(1)/lib/functions