generic: platform/mikrotik: disambiguate SPDX-License-Identifier
[openwrt/staging/chunkeey.git] / package / utils / fuse / Makefile
index 43f1ef4dd74ad5678f807cc260667907fdfd0ae7..be80b03c42e0834af9f54f529ccc4fcdd17c97b5 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2014 OpenWrt.org
+#
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,16 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=fuse
-PKG_VERSION:=2.9.3
-PKG_RELEASE:=1
+PKG_VERSION:=2.9.7
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=33cae22ca50311446400daf8a6255c6a
+PKG_SOURCE_URL:=https://github.com/libfuse/libfuse/releases/download/$(PKG_NAME)-$(PKG_VERSION)
+PKG_HASH:=832432d1ad4f833c20e13b57cf40ce5277a9d33e483205fc63c78111b3358874
 
 PKG_LICENSE:=LGPLv2.1 GPLv2
 PKG_LICENSE_FILES:=COPYING.LIB COPYING
+PKG_CPE_ID:=cpe:/a:fuse_project:fuse
 
 PKG_INSTALL:=1
 
@@ -55,6 +56,7 @@ $(call Package/fuse/Default)
   TITLE+= (library)
   DEPENDS:=+kmod-fuse +libpthread
   SUBMENU:=Filesystem
+  ABI_VERSION:=1
 endef
 
 define Package/libfuse/description