add initial support for the crisarchitecture used on foxboards to openwrt
[openwrt/staging/chunkeey.git] / rules.mk
index 4bc7dfab48e538aaf511e6051f85b567212fb71d..0ce75f55c0c5dea4be0bd8c572b99aa645658724 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -131,19 +131,6 @@ $(call shvar,$(1))=$$(call $(1))
 export $(call shvar,$(1))
 endef
 
-# Default targets for subdirectory calls
-# Parameters:
-#      1: dependencies for the prepare step
-define default_subtargets
-  %-download %-prepare %-compile %-install %-clean: FORCE
-       $$(MAKE) -C $$* $$(patsubst $$*-%,%,$$@)
-
-  %-compile: %-prepare 
-  %-install: %-compile
-  .SILENT: %-clean
-endef
-
-
 all:
 FORCE: ;
 .PHONY: FORCE