tools/gmp: update to version 5.0.1
[openwrt/staging/chunkeey.git] / rules.mk
index 007e5bc9b2f8176ddfcfbd0b880baf9b8ef9664a..d3521649a52da662301b3f29eafc6486fe60e3b5 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -252,11 +252,11 @@ endef
 # Execute commands under flock
 # $(1) => The shell expression.
 # $(2) => The lock name. If not given, the global lock will be used.
-# $(3) => The filedescriptor used for the lock. Defaults to 1023.
 define locked
-    ( $(STAGING_DIR_HOST)/bin/flock -x $(if $(3),$(3),1023) && \
-      $(1) \
-    ) $(if $(3),$(strip $(3)),1023)>$(TMP_DIR)/.$(if $(2),$(strip $(2)),global).flock
+       SHELL= \
+       $(STAGING_DIR_HOST)/bin/flock \
+               $(TMP_DIR)/.$(if $(2),$(strip $(2)),global).flock \
+               -c '$(subst ','\'',$(1))'
 endef
 
 # file extension